aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/clpeak/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks/clpeak/Makefile')
-rw-r--r--benchmarks/clpeak/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/benchmarks/clpeak/Makefile b/benchmarks/clpeak/Makefile
index 391ee4335f21..5ebee59f2e0e 100644
--- a/benchmarks/clpeak/Makefile
+++ b/benchmarks/clpeak/Makefile
@@ -2,9 +2,12 @@
# $FreeBSD$
PORTNAME= clpeak
-DISTVERSION= 1.1.0-rc2
+DISTVERSION= 1.1.0
CATEGORIES= benchmarks
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES+= db42d30028ba.patch:-p1 # https://github.com/krrishnarraj/clpeak/issues/73
+
MAINTAINER= jmd@FreeBSD.org
COMMENT= Benchmarking tool to measure peak capabilities of opencl devices
@@ -20,6 +23,12 @@ GH_ACCOUNT= krrishnarraj
USE_LDCONFIG= yes
PLIST_FILES= bin/clpeak
+.if !empty(PATCHFILES:Mdb42d30028ba*)
+pre-patch:
+ @${REINPLACE_CMD} -e '/GIT_TAG/s/master/opencl21/' \
+ ${WRKSRC}/cmake/BuildCLHpp.cmake
+.endif
+
post-patch:
@${REINPLACE_CMD} '/install.*LICENSE/d' ${WRKSRC}/CMakeLists.txt