aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/webbench
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks/webbench')
-rw-r--r--benchmarks/webbench/Makefile4
-rw-r--r--benchmarks/webbench/files/patch-Makefile13
2 files changed, 2 insertions, 15 deletions
diff --git a/benchmarks/webbench/Makefile b/benchmarks/webbench/Makefile
index 5163a469a47c..c5436541572f 100644
--- a/benchmarks/webbench/Makefile
+++ b/benchmarks/webbench/Makefile
@@ -16,8 +16,8 @@ COMMENT= Simple forking web benchmark
USE_GETOPT_LONG=yes
-MAKE_ENV+= CPPFLAGS="${CPPFLAGS}" \
- LDFLAGS="${LDFLAGS}"
+MAKE_ENV+= LDFLAGS="${LDFLAGS}"
+MAKE_ARGS+= CFLAGS="${CPPFLAGS} ${CFLAGS}"
.if !defined(NO_INSTALL_MANPAGES)
MAN1= webbench.1
diff --git a/benchmarks/webbench/files/patch-Makefile b/benchmarks/webbench/files/patch-Makefile
deleted file mode 100644
index 192ca29e6b00..000000000000
--- a/benchmarks/webbench/files/patch-Makefile
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile.orig Thu Jan 15 12:09:01 2004
-+++ Makefile Thu Jan 29 20:38:03 2004
-@@ -20,8 +20,8 @@
- install -m 644 debian/changelog $(DESTDIR)$(PREFIX)/share/doc/webbench
- .endif
-
--webbench: webbench.o Makefile
-- $(CC) $(CFLAGS) $(LDFLAGS) -o webbench webbench.o $(LIBS)
-+webbench: Makefile
-+ ${CC} $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o webbench webbench.c $(LIBS)
-
- clean:
- -rm -f *.o webbench *~ core tags