aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/autobench/Makefile6
-rw-r--r--benchmarks/dbench/Makefile2
-rw-r--r--benchmarks/dbs/Makefile2
-rw-r--r--benchmarks/expedite/Makefile2
-rw-r--r--benchmarks/fio/Makefile4
-rw-r--r--benchmarks/flowgrind/Makefile8
-rw-r--r--benchmarks/himenobench/Makefile4
-rw-r--r--benchmarks/hpl/Makefile4
-rw-r--r--benchmarks/imb/Makefile8
-rw-r--r--benchmarks/mdtest/Makefile8
-rw-r--r--benchmarks/nosqlbench/Makefile2
-rw-r--r--benchmarks/nqueens/Makefile2
-rw-r--r--benchmarks/p5-Benchmark-Stopwatch/Makefile4
-rw-r--r--benchmarks/phoronix-test-suite/Makefile4
-rw-r--r--benchmarks/polygraph/Makefile4
-rw-r--r--benchmarks/postal/Makefile2
-rw-r--r--benchmarks/rubygem-railsbench/Makefile2
-rw-r--r--benchmarks/sipp/Makefile2
-rw-r--r--benchmarks/slowloris/Makefile6
-rw-r--r--benchmarks/tsung/Makefile4
-rw-r--r--benchmarks/wrk/Makefile2
21 files changed, 41 insertions, 41 deletions
diff --git a/benchmarks/autobench/Makefile b/benchmarks/autobench/Makefile
index 93973aaf77ca..7d640fe1691b 100644
--- a/benchmarks/autobench/Makefile
+++ b/benchmarks/autobench/Makefile
@@ -14,9 +14,9 @@ COMMENT= Automating the process of benchmarking a web server
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/LICENCE
-RUN_DEPENDS= httperf:${PORTSDIR}/benchmarks/httperf \
- gawk:${PORTSDIR}/lang/gawk \
- gnuplot:${PORTSDIR}/math/gnuplot
+RUN_DEPENDS= httperf:benchmarks/httperf \
+ gawk:lang/gawk \
+ gnuplot:math/gnuplot
USES= gmake perl5 shebangfix
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" DEBUG_FLAGS= \
diff --git a/benchmarks/dbench/Makefile b/benchmarks/dbench/Makefile
index 0d892cc24b66..13a2c17ba165 100644
--- a/benchmarks/dbench/Makefile
+++ b/benchmarks/dbench/Makefile
@@ -12,7 +12,7 @@ COMMENT= Simulation of the Ziff-Davis netbench benchmark
LICENSE= GPLv3
-LIB_DEPENDS= libpopt.so:${PORTSDIR}/devel/popt
+LIB_DEPENDS= libpopt.so:devel/popt
CFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
diff --git a/benchmarks/dbs/Makefile b/benchmarks/dbs/Makefile
index d5f1478f585f..ff981789a4c4 100644
--- a/benchmarks/dbs/Makefile
+++ b/benchmarks/dbs/Makefile
@@ -11,7 +11,7 @@ MASTER_SITES= http://www.kusa.ac.jp/~yukio-m/dbs/software1.1.5/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Distributed network benchmarking system
-RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
+RUN_DEPENDS= gnuplot:math/gnuplot
BUILD_WRKSRC= ${WRKSRC}/obj/${OPSYS}
INSTALL_WRKSRC= ${WRKSRC}/obj/${OPSYS}
diff --git a/benchmarks/expedite/Makefile b/benchmarks/expedite/Makefile
index eb605abfd991..dc938fafd874 100644
--- a/benchmarks/expedite/Makefile
+++ b/benchmarks/expedite/Makefile
@@ -11,7 +11,7 @@ COMMENT= Expedite is a benchmark suite for Evas
LICENSE= BSD2CLAUSE
-LIB_DEPENDS= libefl.so:${PORTSDIR}/devel/efl
+LIB_DEPENDS= libefl.so:devel/efl
DIST_SUBDIR= enlightenment
GNU_CONFIGURE= yes
diff --git a/benchmarks/fio/Makefile b/benchmarks/fio/Makefile
index 4a984ce6f9d7..f471d9f66ec5 100644
--- a/benchmarks/fio/Makefile
+++ b/benchmarks/fio/Makefile
@@ -16,7 +16,7 @@ USES= gmake tar:bzip2
OPTIONS_DEFINE= GNUPLOT EXAMPLES
GNUPLOT_DESC= Support for plotting graphs
-GNUPLOT_BUILD_DEPENDS= ${LOCALBASE}/bin/gnuplot:${PORTSDIR}/math/gnuplot
+GNUPLOT_BUILD_DEPENDS= ${LOCALBASE}/bin/gnuplot:math/gnuplot
.include <bsd.port.options.mk>
@@ -26,7 +26,7 @@ MAKE_ARGS+= YACC=${LOCALBASE}/bin/bison
.endif
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000033
-BUILD_DEPENDS+= flex>0:${PORTSDIR}/textproc/flex
+BUILD_DEPENDS+= flex>0:textproc/flex
MAKE_ARGS+= LEX=${LOCALBASE}/bin/flex
.endif
diff --git a/benchmarks/flowgrind/Makefile b/benchmarks/flowgrind/Makefile
index f869f22b8343..79135b0e8909 100644
--- a/benchmarks/flowgrind/Makefile
+++ b/benchmarks/flowgrind/Makefile
@@ -12,10 +12,10 @@ COMMENT= Measure throughput and other metrics for TCP
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= pcap-config:${PORTSDIR}/net/libpcap
-LIB_DEPENDS= libpcap.so:${PORTSDIR}/net/libpcap \
- libgsl.so:${PORTSDIR}/math/gsl \
- libxmlrpc.so:${PORTSDIR}/net/xmlrpc-c
+BUILD_DEPENDS= pcap-config:net/libpcap
+LIB_DEPENDS= libpcap.so:net/libpcap \
+ libgsl.so:math/gsl \
+ libxmlrpc.so:net/xmlrpc-c
USE_GITHUB= yes
diff --git a/benchmarks/himenobench/Makefile b/benchmarks/himenobench/Makefile
index 6dd7053cd794..f3bb6f2c161d 100644
--- a/benchmarks/himenobench/Makefile
+++ b/benchmarks/himenobench/Makefile
@@ -17,7 +17,7 @@ COMMENT= Tool for measureing performance of floating point operation
LICENSE= LGPL20 # (or later)
-EXTRACT_DEPENDS= lha:${PORTSDIR}/archivers/lha
+EXTRACT_DEPENDS= lha:archivers/lha
USES= zip
NO_WRKSUBDIR= yes
@@ -27,7 +27,7 @@ OPTIONS_DEFINE= ICC IFC OPTIMIZED_CFLAGS
OPTIONS_SUB= yes
ICC_DESC= Intel C compiler support
-ICC_BUILD_DEPENDS= ${LOCALBASE}/intel_cc_80/bin/icc:${PORTSDIR}/lang/icc
+ICC_BUILD_DEPENDS= ${LOCALBASE}/intel_cc_80/bin/icc:lang/icc
IFC_DESC= Intel Fortran compiler support
IFC_USES= fortran:ifort
IFC_USES_OFF= fortran
diff --git a/benchmarks/hpl/Makefile b/benchmarks/hpl/Makefile
index fd4f7db677aa..f14afcee0fd2 100644
--- a/benchmarks/hpl/Makefile
+++ b/benchmarks/hpl/Makefile
@@ -10,8 +10,8 @@ MASTER_SITES= NETLIB/benchmark/hpl
MAINTAINER= oliver@FreeBSD.org
COMMENT= High Performance Computing Linpack Benchmark
-LIB_DEPENDS= libblas.so:${PORTSDIR}/math/blas \
- libmpich.so:${PORTSDIR}/net/mpich2
+LIB_DEPENDS= libblas.so:math/blas \
+ libmpich.so:net/mpich2
USES= fortran
USE_LDCONFIG= yes
diff --git a/benchmarks/imb/Makefile b/benchmarks/imb/Makefile
index 8b9d406a31a5..d60b5aaf67db 100644
--- a/benchmarks/imb/Makefile
+++ b/benchmarks/imb/Makefile
@@ -32,11 +32,11 @@ OPTIONS_DEFINE= CHECK_RESULTS DOCS OPENMPI
CHECK_RESULTS_DESC= Check results (not valid as real benchmark data)
CHECK_RESULTS_CFLAGS= -DCHECK
-OPENMPI_BUILD_DEPENDS= ${LOCALBASE}/mpi/openmpi/lib/libmpi.so:${PORTSDIR}/net/openmpi
-OPENMPI_RUN_DEPENDS= ${LOCALBASE}/mpi/openmpi/bin/mpirun:${PORTSDIR}/net/openmpi
+OPENMPI_BUILD_DEPENDS= ${LOCALBASE}/mpi/openmpi/lib/libmpi.so:net/openmpi
+OPENMPI_RUN_DEPENDS= ${LOCALBASE}/mpi/openmpi/bin/mpirun:net/openmpi
OPENMPI_MAKE_ENV= MPI_HOME=${LOCALBASE}/mpi/openmpi
-OPENMPI_BUILD_DEPENDS_OFF= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
-OPENMPI_RUN_DEPENDS_OFF= ${LOCALBASE}/bin/mpirun:${PORTSDIR}/net/mpich2
+OPENMPI_BUILD_DEPENDS_OFF= ${LOCALBASE}/bin/mpicc:net/mpich2
+OPENMPI_RUN_DEPENDS_OFF= ${LOCALBASE}/bin/mpirun:net/mpich2
OPENMPI_MAKE_ENV_OFF= MPI_HOME=${LOCALBASE}
do-install:
diff --git a/benchmarks/mdtest/Makefile b/benchmarks/mdtest/Makefile
index a3b72e30c4d0..5a8aa99aebe2 100644
--- a/benchmarks/mdtest/Makefile
+++ b/benchmarks/mdtest/Makefile
@@ -23,12 +23,12 @@ PORTEXAMPLES= *
OPTIONS_DEFINE= OPENMPI EXAMPLES
OPENMPI_DESC= Use Open MPI instead of MPICH2
-OPENMPI_BUILD_DEPENDS= ${LOCALBASE}/mpi/openmpi/bin/mpicc:${PORTSDIR}/net/openmpi
-OPENMPI_RUN_DEPENDS= ${LOCALBASE}/mpi/openmpi/bin/mpirun:${PORTSDIR}/net/openmpi
+OPENMPI_BUILD_DEPENDS= ${LOCALBASE}/mpi/openmpi/bin/mpicc:net/openmpi
+OPENMPI_RUN_DEPENDS= ${LOCALBASE}/mpi/openmpi/bin/mpirun:net/openmpi
OPENMPI_VARS= MPICC=${LOCALBASE}/mpi/openmpi/bin/mpicc
-OPENMPI_BUILD_DEPENDS_OFF= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
-OPENMPI_RUN_DEPENDS_OFF= ${LOCALBASE}/bin/mpirun:${PORTSDIR}/net/mpich2
+OPENMPI_BUILD_DEPENDS_OFF= ${LOCALBASE}/bin/mpicc:net/mpich2
+OPENMPI_RUN_DEPENDS_OFF= ${LOCALBASE}/bin/mpirun:net/mpich2
OPENMPI_VARS_OFF= MPICC=${LOCALBASE}/bin/mpicc
do-build:
diff --git a/benchmarks/nosqlbench/Makefile b/benchmarks/nosqlbench/Makefile
index ed7da24bf29e..accb6b7007b7 100644
--- a/benchmarks/nosqlbench/Makefile
+++ b/benchmarks/nosqlbench/Makefile
@@ -11,7 +11,7 @@ COMMENT= Micro-benchmarking NoSQL storage
LICENSE= BSD2CLAUSE
-LIB_DEPENDS= libleveldb.so:${PORTSDIR}/databases/leveldb
+LIB_DEPENDS= libleveldb.so:databases/leveldb
DATE= 20151214
USES= cmake tar:bzip2
diff --git a/benchmarks/nqueens/Makefile b/benchmarks/nqueens/Makefile
index b6ce2bdd2444..6c59879d19a2 100644
--- a/benchmarks/nqueens/Makefile
+++ b/benchmarks/nqueens/Makefile
@@ -30,7 +30,7 @@ PROGS= qn24b_base
.if ${PORT_OPTIONS:MMPI}
MPICC?= ${LOCALBASE}/mpich/bin/mpicc
-BUILD_DEPENDS= ${MPICC}:${PORTSDIR}/net/mpich
+BUILD_DEPENDS= ${MPICC}:net/mpich
PROGS+= qn24b_mpi
.endif
diff --git a/benchmarks/p5-Benchmark-Stopwatch/Makefile b/benchmarks/p5-Benchmark-Stopwatch/Makefile
index c6ea168307aa..ccca754598b3 100644
--- a/benchmarks/p5-Benchmark-Stopwatch/Makefile
+++ b/benchmarks/p5-Benchmark-Stopwatch/Makefile
@@ -11,9 +11,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Simple timing of stages of your code
-RUN_DEPENDS= p5-Clone>=0:${PORTSDIR}/devel/p5-Clone
+RUN_DEPENDS= p5-Clone>=0:devel/p5-Clone
BUILD_DEPENDS:= ${RUN_DEPENDS}
-BUILD_DEPENDS+= p5-Test-LongString>=0:${PORTSDIR}/devel/p5-Test-LongString
+BUILD_DEPENDS+= p5-Test-LongString>=0:devel/p5-Test-LongString
USES= perl5
USE_PERL5= configure
diff --git a/benchmarks/phoronix-test-suite/Makefile b/benchmarks/phoronix-test-suite/Makefile
index b43cb0b3c14d..904a4293aae5 100644
--- a/benchmarks/phoronix-test-suite/Makefile
+++ b/benchmarks/phoronix-test-suite/Makefile
@@ -20,8 +20,8 @@ WANT_PHP_CLI= yes
NO_BUILD= yes
WRKSRC= ${WRKDIR}/phoronix-test-suite
-RUN_DEPENDS+= fpdf>0:${PORTSDIR}/print/fpdf
-RUN_DEPENDS+= cmake:${PORTSDIR}/devel/cmake
+RUN_DEPENDS+= fpdf>0:print/fpdf
+RUN_DEPENDS+= cmake:devel/cmake
PORTDATA= *
PORTDOCS= *
diff --git a/benchmarks/polygraph/Makefile b/benchmarks/polygraph/Makefile
index aef4f59b66ee..cae6e8c779dc 100644
--- a/benchmarks/polygraph/Makefile
+++ b/benchmarks/polygraph/Makefile
@@ -26,12 +26,12 @@ OPTIONS_DEFINE= DOCS GNUPLOT GSSAPI LDNS PERL SSL ZLIB
OPTIONS_DEFAULT= SSL ZLIB
GNUPLOT_DESC= GNUPlot for full reporting functionality
-GNUPLOT_RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
+GNUPLOT_RUN_DEPENDS= gnuplot:math/gnuplot
GSSAPI_USES= gssapi:mit
GSSAPI_CONFIGURE_ON= --with-kerberos=${KRB5CONFIG} ${GSSAPI_CONFIGURE_ARGS}
GSSAPI_CONFIGURE_OFF= --without-kerberos
LDNS_DESC= DNS zone file support via libldns
-LDNS_LIB_DEPENDS= libldns.so:${PORTSDIR}/dns/ldns
+LDNS_LIB_DEPENDS= libldns.so:dns/ldns
LDNS_CONFIGURE_ON= --with-ldns=${LOCALBASE}/bin/ldns-config
LDNS_CONFIGURE_OFF= --without-ldns
SSL_DESC= SSL/HTTPS support
diff --git a/benchmarks/postal/Makefile b/benchmarks/postal/Makefile
index d47ab08aee0d..4453eee3f4c6 100644
--- a/benchmarks/postal/Makefile
+++ b/benchmarks/postal/Makefile
@@ -28,7 +28,7 @@ OPTIONS_RADIO= TLS
OPTIONS_RADIO_TLS= GNUTLS OPENSSL
OPTIONS_DEFAULT= OPENSSL
-GNUTLS_LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
+GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
GNUTLS_USES= pkgconfig
GNUTLS_CONFIGURE_OFF= --disable-gnutls
GNUTLS_CPPFLAGS= $$(pkg-config --cflags gnutls)
diff --git a/benchmarks/rubygem-railsbench/Makefile b/benchmarks/rubygem-railsbench/Makefile
index d8a3310a6cca..6ce1ea3c5aaa 100644
--- a/benchmarks/rubygem-railsbench/Makefile
+++ b/benchmarks/rubygem-railsbench/Makefile
@@ -23,6 +23,6 @@ PLIST_FILES= bin/railsbench
OPTIONS_DEFINE= GRUFF
GRUFF_DESC= Plotting of perf data support using gruff
-GRUFF_RUN_DEPENDS= rubygem-gruff>=0.2.8:${PORTSDIR}/graphics/rubygem-gruff
+GRUFF_RUN_DEPENDS= rubygem-gruff>=0.2.8:graphics/rubygem-gruff
.include <bsd.port.mk>
diff --git a/benchmarks/sipp/Makefile b/benchmarks/sipp/Makefile
index 8a32aa308a91..28440ce544ea 100644
--- a/benchmarks/sipp/Makefile
+++ b/benchmarks/sipp/Makefile
@@ -33,7 +33,7 @@ RTPSTREAM_CONFIGURE_WITH= rtpstream
OPENSSL_CONFIGURE_WITH= openssl
OPENSSL_USE= openssl=yes
-GSL_LIB_DEPENDS= libgsl.so:${PORTSDIR}/math/gsl
+GSL_LIB_DEPENDS= libgsl.so:math/gsl
PCAP_FILES= dtmf_2833_0.pcap dtmf_2833_1.pcap dtmf_2833_2.pcap \
dtmf_2833_3.pcap dtmf_2833_4.pcap dtmf_2833_5.pcap \
diff --git a/benchmarks/slowloris/Makefile b/benchmarks/slowloris/Makefile
index 0dfb7c07ac5f..1c5670eebeb6 100644
--- a/benchmarks/slowloris/Makefile
+++ b/benchmarks/slowloris/Makefile
@@ -10,8 +10,8 @@ MASTER_SITES= ftp://ftp.renatasystems.org/pub/FreeBSD/ports/distfiles/
MAINTAINER= alexey@renatasystems.org
COMMENT= The low bandwidth, yet greedy and poisonous HTTP client
-RUN_DEPENDS= p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL \
- p5-Getopt-Long>=0:${PORTSDIR}/devel/p5-Getopt-Long
+RUN_DEPENDS= p5-IO-Socket-SSL>=0:security/p5-IO-Socket-SSL \
+ p5-Getopt-Long>=0:devel/p5-Getopt-Long
NO_BUILD= yes
@@ -26,7 +26,7 @@ PERL_THREADS?= yes
.if ${PERL_THREADS} != "yes"
EXTRA_PATCHES+= ${FILESDIR}/extra-nothreads
.else
-RUN_DEPENDS+= p5-threads-shared>=0:${PORTSDIR}/devel/p5-threads-shared
+RUN_DEPENDS+= p5-threads-shared>=0:devel/p5-threads-shared
.endif
do-install:
diff --git a/benchmarks/tsung/Makefile b/benchmarks/tsung/Makefile
index ea5715a99b75..49e5c89df001 100644
--- a/benchmarks/tsung/Makefile
+++ b/benchmarks/tsung/Makefile
@@ -11,8 +11,8 @@ COMMENT= Multi-protocol distributed load testing tool
LICENSE= GPLv2
-BUILD_DEPENDS= erlc:${PORTSDIR}/lang/erlang
-RUN_DEPENDS= erl:${PORTSDIR}/lang/erlang
+BUILD_DEPENDS= erlc:lang/erlang
+RUN_DEPENDS= erl:lang/erlang
USE_PERL5= run
diff --git a/benchmarks/wrk/Makefile b/benchmarks/wrk/Makefile
index 848379226368..7331039a3249 100644
--- a/benchmarks/wrk/Makefile
+++ b/benchmarks/wrk/Makefile
@@ -11,7 +11,7 @@ COMMENT= Modern HTTP benchmarking tool
LICENSE= APACHE20
-LIB_DEPENDS= libluajit-5.1.so:${PORTSDIR}/lang/luajit
+LIB_DEPENDS= libluajit-5.1.so:lang/luajit
USE_GITHUB= yes
GH_ACCOUNT= wg