aboutsummaryrefslogtreecommitdiff
path: root/biology/bowtie2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'biology/bowtie2/Makefile')
-rw-r--r--biology/bowtie2/Makefile26
1 files changed, 17 insertions, 9 deletions
diff --git a/biology/bowtie2/Makefile b/biology/bowtie2/Makefile
index 0f72c9de9c65..74a60bea3624 100644
--- a/biology/bowtie2/Makefile
+++ b/biology/bowtie2/Makefile
@@ -1,10 +1,9 @@
# $FreeBSD$
-PORTNAME= bowtie2
-PORTVERSION= 2.3.3.1
+PORTNAME= bowtie2
DISTVERSIONPREFIX= v
-PORTREVISION= 2
-CATEGORIES= biology
+DISTVERSION= 2.3.5
+CATEGORIES= biology perl5 python
MAINTAINER= jwb@FreeBSD.org
COMMENT= Ultrafast, memory-efficient short read aligner
@@ -13,20 +12,28 @@ LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/LICENSE
# May also work on other 64-bit platforms, but untested
-ONLY_FOR_ARCHS= amd64
+ONLY_FOR_ARCHS= aarch64 amd64
LIB_DEPENDS= libtbb.so:devel/tbb
-USES= gmake perl5 python shebangfix
+USES= gmake localbase:ldflags perl5 python shebangfix
USE_PERL5= run
-SHEBANG_FILES= bowtie2-build bowtie2-inspect scripts/*.pl
-
USE_GITHUB= yes
+
+SHEBANG_FILES= bowtie2 bowtie2-build bowtie2-inspect scripts/*.pl
GH_ACCOUNT= BenLangmead
OPTIONS_DEFINE= DOCS EXAMPLES
+SUB_FILES= bowtie2-test
+
+pre-configure:
+ @${REINPLACE_CMD} \
+ -e 's|^RELEASE_FLAGS|# RELEASE_FLAGS|' \
+ -e 's|tbbmalloc_proxy|tbbmalloc|' \
+ ${WRKSRC}/Makefile
+
post-install:
- ${MKDIR} ${STAGEDIR}${DATADIR}/scripts
+ @${MKDIR} ${STAGEDIR}${DATADIR}/scripts
${INSTALL_PROGRAM} \
${WRKSRC}/bowtie2*-s \
${WRKSRC}/bowtie2*-l \
@@ -35,6 +42,7 @@ post-install:
${WRKSRC}/scripts/*.sh \
${WRKSRC}/scripts/*.pl \
${STAGEDIR}${DATADIR}/scripts
+ ${INSTALL_SCRIPT} ${WRKDIR}/bowtie2-test ${STAGEDIR}${PREFIX}/bin
post-install-DOCS-on:
(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})