aboutsummaryrefslogtreecommitdiff
path: root/biology/fasda-utils/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'biology/fasda-utils/Makefile')
-rw-r--r--biology/fasda-utils/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/biology/fasda-utils/Makefile b/biology/fasda-utils/Makefile
new file mode 100644
index 000000000000..599b34101d8b
--- /dev/null
+++ b/biology/fasda-utils/Makefile
@@ -0,0 +1,28 @@
+PORTNAME= fasda-utils
+DISTVERSION= 0.1.0
+CATEGORIES= biology
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Fast and simple differential analysis extras
+WWW= https://github.com/auerlab/fasda-utils
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}seaborn>=0:math/py-seaborn@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}fastcluster>=0:math/py-fastcluster@${PY_FLAVOR}
+
+USES= python:run shebangfix
+USE_GITHUB= yes
+
+SHEBANG_FILES= Scripts/heatmap.py
+
+GH_ACCOUNT= auerlab
+
+MAKE_ARGS= MANPREFIX=${PREFIX}/share VERSION=${PORTVERSION}
+
+PLIST_FILES= libexec/fasda/heatmap \
+ libexec/fasda/heatmap.py \
+ share/man/man1/fasda-heatmap.1.gz
+
+.include <bsd.port.mk>