aboutsummaryrefslogtreecommitdiff
path: root/cad/sumo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'cad/sumo/Makefile')
-rw-r--r--cad/sumo/Makefile33
1 files changed, 11 insertions, 22 deletions
diff --git a/cad/sumo/Makefile b/cad/sumo/Makefile
index 994a746ab9aa..45992d253992 100644
--- a/cad/sumo/Makefile
+++ b/cad/sumo/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= sumo
-DISTVERSION= 0.31.0
+DISTVERSION= 1.2.0
CATEGORIES= cad
MASTER_SITES= http://www.dlr.de/ts/en/Portaldata/16/Resources/projekte/sumo/
DISTFILES= ${PORTNAME}-src-${DISTVERSIONFULL}${EXTRACT_SUFX}
@@ -9,9 +9,6 @@ DISTFILES= ${PORTNAME}-src-${DISTVERSIONFULL}${EXTRACT_SUFX}
MAINTAINER= enriquefynn@gmail.com
COMMENT= Traffic simulation suite for road vehicles, public transportation, etc
-LICENSE= GPLv3
-LICENSE_FILE= ${WRKSRC}/COPYING
-
BROKEN_powerpc64= fails to configure: xerces-lib not found in /usr/local/lib
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
@@ -23,25 +20,17 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libtiff.so:graphics/tiff \
libxerces-c.so:textproc/xerces-c3
-USES= jpeg zip
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-proj-gdal=${LOCALBASE} \
- --with-xerces-libraries=${LOCALBASE}/lib \
- --disable-debug
+USES= cmake jpeg python shebangfix zip
+SHEBANG_FILES= tools/*.py tools/*/*.py \
+ tools/*/*/*.py tools/*/*/*/*.py \
+ tools/*/*/*/*/*/*.py \
+ tools/game/A10KW/build.sh \
+ tools/game/rebuild_networks.sh \
+ tools/build/rebuild_cscope.sh \
+ tools/build/dailyUpdateMakeGCC.sh
+
+python_OLD_CMD+="/usr/bin/env python"
USE_GL= gl glu
USE_XORG= x11 xcursor xext xfixes xft xi xrandr xrender
-OPTIONS_DEFINE= DOCS # the GUI option is possible (--without-fox-config), but it is broken, and it doesn't seem important to have. https://github.com/DLR-TS/sumo/issues/3655
-
-DOCS_DISTFILES= ${PORTNAME}-doc-${DISTVERSION}${EXTRACT_SUFX}
-DOCS_USES= shebangfix
-DOCS_VARS= SHEBANG_FILES=docs/tutorial/*/*.py
-
-PORTDOCS= *
-
-do-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- @cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
- @${FIND} ${STAGEDIR}${DOCSDIR} -d -empty -delete
-
.include <bsd.port.mk>