aboutsummaryrefslogtreecommitdiff
path: root/cad
diff options
context:
space:
mode:
Diffstat (limited to 'cad')
-rw-r--r--cad/appcsxcad/Makefile2
-rw-r--r--cad/caneda/Makefile2
-rw-r--r--cad/freecad/Makefile2
-rw-r--r--cad/ktechlab/Makefile4
-rw-r--r--cad/ldview/Makefile2
-rw-r--r--cad/leocad/Makefile2
-rw-r--r--cad/librecad/Makefile2
-rw-r--r--cad/librepcb/Makefile2
-rw-r--r--cad/meshlab/Makefile2
-rw-r--r--cad/openroad/Makefile2
-rw-r--r--cad/openscad-devel/Makefile2
-rw-r--r--cad/openscad/Makefile2
-rw-r--r--cad/py-pyfda/Makefile2
-rw-r--r--cad/qcad/Makefile2
-rw-r--r--cad/qcsxcad/Makefile2
-rw-r--r--cad/qelectrotech/Makefile2
-rw-r--r--cad/qucs-s/Makefile2
-rw-r--r--cad/veroroute/Makefile2
18 files changed, 19 insertions, 19 deletions
diff --git a/cad/appcsxcad/Makefile b/cad/appcsxcad/Makefile
index 616a31d79105..eeacd1ff5ed4 100644
--- a/cad/appcsxcad/Makefile
+++ b/cad/appcsxcad/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= libCSXCAD.so:cad/csxcad \
libvtkCommonCore-9.1.so:math/vtk9
USES= cmake jpeg pkgconfig qt:5 xorg
-USE_QT= core gui sql widgets xml buildtools_build qmake_build
+USE_QT= core gui sql widgets xml buildtools:build qmake:build
USE_XORG= ice sm x11 xext xt
USE_LDCONFIG= yes
diff --git a/cad/caneda/Makefile b/cad/caneda/Makefile
index 94e7942177e7..6f1303bbfb8b 100644
--- a/cad/caneda/Makefile
+++ b/cad/caneda/Makefile
@@ -17,7 +17,7 @@ USES= cmake compiler:c++11-lang desktop-file-utils qt:5 \
USE_GITHUB= yes
GH_ACCOUNT= Caneda
GH_PROJECT= Caneda
-USE_QT= core gui printsupport svg widgets buildtools_build linguisttools_build qmake_build
+USE_QT= core gui printsupport svg widgets buildtools:build linguisttools:build qmake:build
CMAKE_ARGS= -DQWT_INCLUDE_DIR=${LOCALBASE}/include/qt5/qwt6 -DQWT_LIBRARY=${LOCALBASE}/lib/qt5/libqwt6.so
diff --git a/cad/freecad/Makefile b/cad/freecad/Makefile
index e31e81f92500..ed6b37266a62 100644
--- a/cad/freecad/Makefile
+++ b/cad/freecad/Makefile
@@ -41,7 +41,7 @@ USE_GITHUB= yes
USE_XORG= ice sm x11 xext xt
USE_GL= gl glu
USE_QT= buildtools concurrent core declarative gui location network \
- opengl printsupport qmake_build svg webchannel webengine \
+ opengl printsupport qmake:build svg webchannel webengine \
widgets xml xmlpatterns
USE_LDCONFIG= yes
diff --git a/cad/ktechlab/Makefile b/cad/ktechlab/Makefile
index fefbecc51cd9..64df80300209 100644
--- a/cad/ktechlab/Makefile
+++ b/cad/ktechlab/Makefile
@@ -17,13 +17,13 @@ USES= cmake compiler:c++11-lang desktop-file-utils gnome kde:5 \
localbase qt:5 shared-mime-info xorg
USE_GITHUB= yes
USE_QT= concurrent core dbus gui network printsupport widgets xml \
- qmake_build buildtools_build
+ qmake:build buildtools:build
USE_KDE= auth bookmarks codecs completion config configwidgets coreaddons \
crash guiaddons i18n iconthemes init itemviews jobwidgets js \
kdelibs4support khtml kio notifications parts service solid \
sonnet syntaxhighlighting texteditor textwidgets unitconversion \
widgetsaddons windowsystem xmlgui \
- doctools_build
+ doctools:build
USE_GNOME= glib20
USE_XORG= x11
diff --git a/cad/ldview/Makefile b/cad/ldview/Makefile
index 9d2cd2bf353a..cc59884a84d1 100644
--- a/cad/ldview/Makefile
+++ b/cad/ldview/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= bash:shells/bash \
ldraw>0:cad/ldraw
USES= desktop-file-utils gl gmake jpeg qmake qt:5 shared-mime-info shebangfix xorg
-USE_QT= core gui linguist opengl printsupport widgets buildtools_build qmake_build
+USE_QT= core gui linguist opengl printsupport widgets buildtools:build qmake:build
USE_GL= gl glu
USE_XORG= x11
diff --git a/cad/leocad/Makefile b/cad/leocad/Makefile
index db31f4cca4fe..0d268b466615 100644
--- a/cad/leocad/Makefile
+++ b/cad/leocad/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= ldraw>0:cad/ldraw
USES= compiler:c++11-lang cpe desktop-file-utils gl qmake qt:5 shared-mime-info xorg
USE_GITHUB= yes
GH_ACCOUNT= leozide
-USE_QT= core gui concurrent network opengl printsupport widgets xml buildtools_build linguisttools_build
+USE_QT= core gui concurrent network opengl printsupport widgets xml buildtools:build linguisttools:build
USE_GL= gl
QMAKE_ARGS= INSTALL_PREFIX=${PREFIX} MAN_DIR=${PREFIX}/man/man1 LDRAW_LIBRARY_PATH=${PREFIX}/share/ldraw
diff --git a/cad/librecad/Makefile b/cad/librecad/Makefile
index 4eeef0830510..ead37ec9f942 100644
--- a/cad/librecad/Makefile
+++ b/cad/librecad/Makefile
@@ -23,7 +23,7 @@ GH_ACCOUNT= LibreCAD
GH_PROJECT= LibreCAD
USE_GL= gl
USE_QT= core gui printsupport svg widgets \
- buildtools_build linguisttools_build
+ buildtools:build linguisttools:build
QMAKE_ARGS+= BOOST_DIR="${LOCALBASE}"
diff --git a/cad/librepcb/Makefile b/cad/librepcb/Makefile
index 338293b21e4e..efc3c7edc2c7 100644
--- a/cad/librepcb/Makefile
+++ b/cad/librepcb/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
USES= cmake compiler:c++11-lang desktop-file-utils gl qt:5 shared-mime-info zip
USE_QT= concurrent core gui network opengl printsupport sql svg xml widgets \
- buildtools_build linguisttools_build testlib_build qmake_build
+ buildtools:build linguisttools:build testlib:build qmake:build
USE_GL= gl
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
diff --git a/cad/meshlab/Makefile b/cad/meshlab/Makefile
index e4f40a9c8cab..10a66a614883 100644
--- a/cad/meshlab/Makefile
+++ b/cad/meshlab/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libmpirxx.so:math/mpir
USES= dos2unix gl qmake:outsource qt:5
USE_GL= gl glu glew
-USE_QT= buildtools_build core gui network \
+USE_QT= buildtools:build core gui network \
opengl script xml xmlpatterns widgets
USE_GITHUB= yes
GH_ACCOUNT= cnr-isti-vclab
diff --git a/cad/openroad/Makefile b/cad/openroad/Makefile
index d53b4ef050a6..e24d081da476 100644
--- a/cad/openroad/Makefile
+++ b/cad/openroad/Makefile
@@ -28,7 +28,7 @@ LIB_DEPENDS= libcudd.so:math/cudd \
libspdlog.so:devel/spdlog
USES= bison compiler:c++17-lang cmake eigen:3 qt:5 localbase:ldflags python:3.7+,build readline tcl:86 # the code asks for tcl-87, but build fails: https://github.com/The-OpenROAD-Project/OpenROAD/issues/508
-USE_QT= core gui widgets buildtools_build qmake_build
+USE_QT= core gui widgets buildtools:build qmake:build
USE_GITHUB= yes
GH_ACCOUNT= The-OpenROAD-Project
diff --git a/cad/openscad-devel/Makefile b/cad/openscad-devel/Makefile
index 4f47578cc698..8408023a64e7 100644
--- a/cad/openscad-devel/Makefile
+++ b/cad/openscad-devel/Makefile
@@ -35,7 +35,7 @@ USES= bison cmake compiler:c++14-lang cpe desktop-file-utils eigen:3 gettext \
USE_GITHUB= yes
USE_GL= gl glu glew
USE_GNOME= cairo glib20 libxml2
-USE_QT= buildtools_build core concurrent_build dbus gui multimedia qmake_build svg widgets
+USE_QT= buildtools:build core concurrent:build dbus gui multimedia qmake:build svg widgets
USE_XORG= x11
GH_ACCOUNT= microsoft:mimalloc
GH_PROJECT= MCAD:mcad mimalloc:mimalloc
diff --git a/cad/openscad/Makefile b/cad/openscad/Makefile
index bebfb2e4ef2c..1dbe9e9e148d 100644
--- a/cad/openscad/Makefile
+++ b/cad/openscad/Makefile
@@ -31,7 +31,7 @@ USES= bison compiler:c++14-lang cpe desktop-file-utils eigen:3 gettext \
USE_GITHUB= yes
USE_GL= gl glu glew
USE_GNOME= glib20 libxml2
-USE_QT= buildtools_build core concurrent_build dbus gui multimedia widgets
+USE_QT= buildtools:build core concurrent:build dbus gui multimedia widgets
USE_XORG= x11
GH_TAGNAME= 41f58fe57c03457a3a8b4dc541ef5654ec3e8c78
QMAKE_ARGS= CONFIG+="experimental" VERSION=${PORTVERSION}
diff --git a/cad/py-pyfda/Makefile b/cad/py-pyfda/Makefile
index 7c8dc8fe1b71..62a58cfb2658 100644
--- a/cad/py-pyfda/Makefile
+++ b/cad/py-pyfda/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}docutils>0:textproc/py-docutils@${PY_FLAVOR}
USES= python:3.7+ pyqt:5
USE_PYTHON= distutils autoplist
-USE_PYQT= pyqt5_run
+USE_PYQT= pyqt5:run
NO_ARCH= yes
post-extract:
diff --git a/cad/qcad/Makefile b/cad/qcad/Makefile
index 53cf330b187e..1b46846931d9 100644
--- a/cad/qcad/Makefile
+++ b/cad/qcad/Makefile
@@ -21,7 +21,7 @@ BUILD_DEPENDS= bash:shells/bash \
USES= compiler:c++11-lang gl gmake qmake qt:5
USE_GITHUB= yes
USE_LDCONFIG= yes
-USE_QT= buildtools qmake_build \
+USE_QT= buildtools qmake:build \
designer gui help imageformats network opengl script \
scripttools sql svg uitools xml xmlpatterns webkit
USE_GL= glu
diff --git a/cad/qcsxcad/Makefile b/cad/qcsxcad/Makefile
index 9874742a7c82..8fc566507178 100644
--- a/cad/qcsxcad/Makefile
+++ b/cad/qcsxcad/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= libCSXCAD.so:cad/csxcad \
libvtkCommonCore-9.1.so:math/vtk9
USES= cmake gl jpeg pkgconfig qt:5 xorg
-USE_QT= core gui opengl sql widgets xml buildtools_build qmake_build
+USE_QT= core gui opengl sql widgets xml buildtools:build qmake:build
USE_XORG= ice sm x11 xext xt
USE_GL= gl opengl
USE_LDCONFIG= yes
diff --git a/cad/qelectrotech/Makefile b/cad/qelectrotech/Makefile
index b38c32b65592..30c195a89975 100644
--- a/cad/qelectrotech/Makefile
+++ b/cad/qelectrotech/Makefile
@@ -18,7 +18,7 @@ USES= compiler:c++11-lib desktop-file-utils gl kde:5 qmake qt:5 \
USE_GL= gl
USE_QT= concurrent core gui network printsupport sql sql-sqlite3 \
svg widgets xml \
- buildtools_build
+ buildtools:build
USE_KDE= coreaddons widgetsaddons
OPTIONS_DEFINE= DEBUG DOCS
diff --git a/cad/qucs-s/Makefile b/cad/qucs-s/Makefile
index 52cb64ae6d3f..a4f194090049 100644
--- a/cad/qucs-s/Makefile
+++ b/cad/qucs-s/Makefile
@@ -11,7 +11,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
USES= cmake qt:5
-USE_QT= core gui printsupport svg widgets buildtools_build linguisttools_build qmake_build
+USE_QT= core gui printsupport svg widgets buildtools:build linguisttools:build qmake:build
USE_GITHUB= yes
GH_ACCOUNT= ra3xdh
diff --git a/cad/veroroute/Makefile b/cad/veroroute/Makefile
index f0a15efcdb13..8e27bd706edc 100644
--- a/cad/veroroute/Makefile
+++ b/cad/veroroute/Makefile
@@ -12,7 +12,7 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/../licenses/license_GPLv3.txt
USES= compiler:c++11-lang gl qmake qt:5
-USE_QT= core gui network widgets buildtools_build
+USE_QT= core gui network widgets buildtools:build
USE_GL= gl
WRKSRC= ${WRKDIR}/VeroRoute