aboutsummaryrefslogtreecommitdiff
path: root/chinese/fcitx5-chewing/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/fcitx5-chewing/Makefile')
-rw-r--r--chinese/fcitx5-chewing/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/chinese/fcitx5-chewing/Makefile b/chinese/fcitx5-chewing/Makefile
new file mode 100644
index 000000000000..bc808dc0d136
--- /dev/null
+++ b/chinese/fcitx5-chewing/Makefile
@@ -0,0 +1,24 @@
+# Created by: Ka Ho Ng <khng300@gmail.com>
+# $FreeBSD$
+
+PORTNAME= fcitx5-chewing
+DISTVERSION= 5.0.2
+CATEGORIES= chinese textproc
+
+MAINTAINER= khng300@gmail.com
+COMMENT= Chewing support for Fcitx5
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/LICENSES/GPL-2.0-or-later.txt
+
+LIB_DEPENDS= libchewing.so:chinese/libchewing \
+ libFcitx5Core.so:textproc/fcitx5
+
+USES= compiler:c++17-lang gettext-tools cmake kde:5 pkgconfig
+
+USE_GITHUB= yes
+GH_ACCOUNT= fcitx
+
+USE_KDE= ecm
+
+.include <bsd.port.mk>