aboutsummaryrefslogtreecommitdiff
path: root/chinese/fcitx5-table-extra/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/fcitx5-table-extra/Makefile')
-rw-r--r--chinese/fcitx5-table-extra/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/chinese/fcitx5-table-extra/Makefile b/chinese/fcitx5-table-extra/Makefile
new file mode 100644
index 000000000000..27f85da6cc2e
--- /dev/null
+++ b/chinese/fcitx5-table-extra/Makefile
@@ -0,0 +1,26 @@
+# Created by: Ka Ho Ng <khng300@gmail.com>
+# $FreeBSD$
+
+PORTNAME= fcitx5-table-extra
+DISTVERSION= 5.0.1
+CATEGORIES= chinese textproc
+
+MAINTAINER= khng300@gmail.com
+COMMENT= Extra table support for Fcitx5
+
+LICENSE= GPLv2+ GPLv3
+LICENSE_COMB= multi
+
+LIB_DEPENDS= libIMETable.so:chinese/libime \
+ libFcitx5Core.so:textproc/fcitx5
+
+USES= gettext-tools cmake kde:5
+
+USE_GITHUB= yes
+GH_ACCOUNT= fcitx
+
+USE_KDE= ecm
+
+INSTALL_TARGET= install
+
+.include <bsd.port.mk>