aboutsummaryrefslogtreecommitdiff
path: root/comms/hidapi/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/hidapi/Makefile')
-rw-r--r--comms/hidapi/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/comms/hidapi/Makefile b/comms/hidapi/Makefile
index 7cc1fc5f1b72..2b512697cd62 100644
--- a/comms/hidapi/Makefile
+++ b/comms/hidapi/Makefile
@@ -2,27 +2,24 @@
PORTNAME= hidapi
DISTVERSIONPREFIX= ${PORTNAME}-
-DISTVERSION= 0.8.0-rc1
-PORTREVISION= 3
+DISTVERSION= 0.10.1
CATEGORIES= comms
-MAINTAINER= tijl@FreeBSD.org
+MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Library to access USB HID-class devices
LICENSE= BSD3CLAUSE GPLv3
LICENSE_COMB= dual
+USES= autoreconf gettext-tools iconv:wchar_t libtool localbase \
+ pkgconfig
+
USE_GITHUB= yes
-GH_ACCOUNT= signal11
+GH_ACCOUNT= libusb
-USES= autoreconf gettext-tools iconv:wchar_t libtool
GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
-PORTDOCS= *
-
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
+USE_LDCONFIG= yes
OPTIONS_DEFINE= DOCS