aboutsummaryrefslogtreecommitdiff
path: root/comms/libticables2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/libticables2/Makefile')
-rw-r--r--comms/libticables2/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/comms/libticables2/Makefile b/comms/libticables2/Makefile
new file mode 100644
index 000000000000..92844656f322
--- /dev/null
+++ b/comms/libticables2/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: libticables2
+# Date created: 11 October 2006
+# Whom: Tijl Coosemans <tijl@ulyssis.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libticables2
+PORTVERSION= 1.0.0
+CATEGORIES= comms
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gtktiemu
+DISTNAME= ${PORTNAME}-20060925
+
+MAINTAINER= tijl@ulyssis.org
+COMMENT= TI calculator link cables library
+
+LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
+
+WRKSRC= ${WRKDIR}/libticables
+
+USE_AUTOTOOLS= libtool:15
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= glib20 gnomehack pkgconfig
+USE_LDCONFIG= yes
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB= NLS=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB= NLS="@comment "
+.endif
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"\
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+post-patch:
+ @${REINPLACE_CMD} -e 's|<stdint\.h>|<inttypes.h>|' \
+ ${WRKSRC}/src/linux/ioports.c
+.endif
+
+.include <bsd.port.post.mk>