aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
Diffstat (limited to 'comms')
-rw-r--r--comms/atslog/Makefile2
-rw-r--r--comms/p5-Device-Modem/Makefile9
-rw-r--r--comms/p5-Device-SerialPort/Makefile3
-rw-r--r--comms/p5-Fax-Hylafax-Client/Makefile3
4 files changed, 8 insertions, 9 deletions
diff --git a/comms/atslog/Makefile b/comms/atslog/Makefile
index 50d1e6da4a94..1c107f26258f 100644
--- a/comms/atslog/Makefile
+++ b/comms/atslog/Makefile
@@ -19,7 +19,7 @@ WWW_DESC= Install web interface
WWWGD_DESC= Graphic reports
GNU_CONFIGURE= yes
-USE_PERL5= yes
+USES= perl5
USE_RC_SUBR= ${PORTNAME}d
PORTDOCS= CHANGES ChangeLog DEINSTALL INSTALL LICENSE TODO UPDATING USAGE
SUB_FILES= pkg-message
diff --git a/comms/p5-Device-Modem/Makefile b/comms/p5-Device-Modem/Makefile
index c47e989c4bbc..4e9c5f34611b 100644
--- a/comms/p5-Device-Modem/Makefile
+++ b/comms/p5-Device-Modem/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Device-Modem
-# Date created: 22 July 2003
-# Whom: Anders Nordby <anders@FreeBSD.org>
-#
+# Created by: Anders Nordby <anders@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Device-Modem
PORTVERSION= 1.56
@@ -17,7 +13,8 @@ COMMENT= Perl class to interface generic modems (AT-compliant)
BUILD_DEPENDS= p5-Device-SerialPort>=0:${PORTSDIR}/comms/p5-Device-SerialPort
RUN_DEPENDS= p5-Device-SerialPort>=0:${PORTSDIR}/comms/p5-Device-SerialPort
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Device::Modem.3 \
Device::Modem::FAQ.3 \
diff --git a/comms/p5-Device-SerialPort/Makefile b/comms/p5-Device-SerialPort/Makefile
index 548a0c956d41..a44d523fcdd2 100644
--- a/comms/p5-Device-SerialPort/Makefile
+++ b/comms/p5-Device-SerialPort/Makefile
@@ -11,7 +11,8 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:C/0+$//}
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl5 module for simple serial port control
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= modemtest.1
MAN3= Device::SerialPort.3
diff --git a/comms/p5-Fax-Hylafax-Client/Makefile b/comms/p5-Fax-Hylafax-Client/Makefile
index 8f57c4ae5e84..3e6f751e9733 100644
--- a/comms/p5-Fax-Hylafax-Client/Makefile
+++ b/comms/p5-Fax-Hylafax-Client/Makefile
@@ -13,7 +13,8 @@ COMMENT= Simple Perl client for the HylaFAX fax server
BUILD_DEPENDS= p5-Net>=0:${PORTSDIR}/net/p5-Net
RUN_DEPENDS= p5-Net>=0:${PORTSDIR}/net/p5-Net
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Fax::Hylafax::Client.3