aboutsummaryrefslogtreecommitdiff
path: root/converters/bibtexconv/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'converters/bibtexconv/Makefile')
-rw-r--r--converters/bibtexconv/Makefile25
1 files changed, 8 insertions, 17 deletions
diff --git a/converters/bibtexconv/Makefile b/converters/bibtexconv/Makefile
index 3c832e80bf2f..52c552eff12f 100644
--- a/converters/bibtexconv/Makefile
+++ b/converters/bibtexconv/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= bibtexconv
-PORTVERSION= 1.1.11
+PORTVERSION= 1.1.17
CATEGORIES= converters
MASTER_SITES= https://www.uni-due.de/~be0001/bibtexconv/download/
@@ -10,29 +10,20 @@ MAINTAINER= dreibh@iem.uni-due.de
COMMENT= BibTeX Converter
LICENSE= GPLv3+
-LICENSE_FILE= ${WRKSRC}/COPYING.GPL
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libcurl.so:ftp/curl
-GNU_CONFIGURE= yes
-USES= gmake ssl python:3.4+
+USES= bison cmake ssl python:3.4+ shebangfix tar:xz
-PLIST_FILES= bin/bibtexconv bin/bibtexconv-odt bin/ietf2bibtex \
- man/man1/bibtexconv.1.gz man/man1/bibtexconv-odt.1.gz \
- man/man1/ietf2bibtex.1.gz
+SHEBANG_FILES= src/ietf2bibtex
-PORTEXAMPLES= ExampleReferences.bib ODT-Template.odt odt-example.export \
- web-example.export text-example.export
+CMAKE_ARGS= -DCMAKE_INSTALL_DOCDIR=${EXAMPLESDIR} -DCMAKE_INSTALL_MANDIR=${MANPREFIX}/man
OPTIONS_DEFINE= EXAMPLES
-pre-configure:
- @${REINPLACE_CMD} -e 's|install-data-am: install-dist_examplesDATA|install-data-am:|' \
- ${WRKSRC}/src/Makefile.in
- @${REINPLACE_CMD} -e 's|/usr/bin/python3|${PYTHON_CMD}|' ${WRKSRC}/src/ietf2bibtex
-
-post-install-EXAMPLES-on:
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${PORTEXAMPLES:S,^,${WRKSRC}/src/,} ${STAGEDIR}${EXAMPLESDIR}
+# Remove trailing subdir from CMAKE_INSTALL_DOCDIR
+post-patch:
+ @${REINPLACE_CMD} -e 's|/examples||' ${WRKSRC}/src/CMakeLists.txt ${WRKSRC}/src/Images/CMakeLists.txt
.include <bsd.port.mk>