aboutsummaryrefslogtreecommitdiff
path: root/converters/py-rencode/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'converters/py-rencode/Makefile')
-rw-r--r--converters/py-rencode/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/converters/py-rencode/Makefile b/converters/py-rencode/Makefile
index e83f61cebf21..06b157739c4f 100644
--- a/converters/py-rencode/Makefile
+++ b/converters/py-rencode/Makefile
@@ -1,8 +1,7 @@
PORTNAME= rencode
PORTVERSION= 1.0.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= converters devel python
-MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= python@FreeBSD.org
@@ -12,9 +11,17 @@ WWW= https://github.com/aresch/rencode
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cython3>0:lang/cython3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+
USES= cpe python
CPE_VENDOR= ${PORTNAME}_project
-USE_PYTHON= autoplist distutils
+USE_PYTHON= autoplist pep517
+
+USE_GITHUB= yes
+GH_ACCOUNT= aresch
+GH_TAGNAME= 572ff74586d9b1daab904c6f7f7009ce0143bb75
# Make setup.py test target work with setup.py:test_suite
# See: files/patch-setup.py