aboutsummaryrefslogtreecommitdiff
path: root/databases/db4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/db4/Makefile')
-rw-r--r--databases/db4/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/databases/db4/Makefile b/databases/db4/Makefile
index d2fde8bf6cbc..2a08db096c81 100644
--- a/databases/db4/Makefile
+++ b/databases/db4/Makefile
@@ -34,6 +34,14 @@ INSTALLS_SHLIB= yes
INSTALL_TARGET= install install_docs
.endif
+# the db install_docs target installs an empty directory, kill it
+# (it's not packaged and it's not needed):
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${RMDIR} ${PREFIX}/share/doc/db4/ref/splash
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/${CONFIGURE_SCRIPT}