aboutsummaryrefslogtreecommitdiff
path: root/databases/mysqlwsrep57-server/files/patch-rapid_unittest_gunit_xplugin_CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'databases/mysqlwsrep57-server/files/patch-rapid_unittest_gunit_xplugin_CMakeLists.txt')
-rw-r--r--databases/mysqlwsrep57-server/files/patch-rapid_unittest_gunit_xplugin_CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/databases/mysqlwsrep57-server/files/patch-rapid_unittest_gunit_xplugin_CMakeLists.txt b/databases/mysqlwsrep57-server/files/patch-rapid_unittest_gunit_xplugin_CMakeLists.txt
new file mode 100644
index 000000000000..d968a7daa022
--- /dev/null
+++ b/databases/mysqlwsrep57-server/files/patch-rapid_unittest_gunit_xplugin_CMakeLists.txt
@@ -0,0 +1,18 @@
+--- rapid/unittest/gunit/xplugin/CMakeLists.txt.orig 2016-03-28 18:06:12 UTC
++++ rapid/unittest/gunit/xplugin/CMakeLists.txt
+@@ -65,7 +65,6 @@ ENDIF()
+ ADD_DEFINITIONS(${GMOCK_CFLAGS} -DBOOST_ALL_NO_LIB -DBOOST_NO_AUTO_PTR -DUSE_MYSQLX_FULL_PROTO)
+
+ INCLUDE_DIRECTORIES(SYSTEM
+- ${BOOST_INCLUDE_DIR}
+ ${PROTOBUF_INCLUDE_DIRS}
+ ${SSL_INCLUDE_DIRS}
+ ${LIBEVENT_INCLUDE_DIR}
+@@ -75,6 +74,7 @@ INCLUDE_DIRECTORIES(SYSTEM
+ )
+
+ INCLUDE_DIRECTORIES(
++ ${BOOST_INCLUDE_DIR}
+ ${CMAKE_SOURCE_DIR}/testing/include
+ ${PROJECT_SOURCE_DIR}/rapid/plugin/x/ngs/include
+ ${PROJECT_SOURCE_DIR}/rapid/plugin/x/ngs/include/ngs