aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBD-SQLite/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/p5-DBD-SQLite/Makefile')
-rw-r--r--databases/p5-DBD-SQLite/Makefile15
1 files changed, 3 insertions, 12 deletions
diff --git a/databases/p5-DBD-SQLite/Makefile b/databases/p5-DBD-SQLite/Makefile
index 6f53b8cf36c9..03f22093c8fe 100644
--- a/databases/p5-DBD-SQLite/Makefile
+++ b/databases/p5-DBD-SQLite/Makefile
@@ -19,7 +19,8 @@ COMMENT= Provides access to SQLite3 databases through the DBI
# than the bundled version and has an incompatible DB file format.
# In this way we can be sure DBD::SQLite can interoperate with
# databases/sqlite3.
-BUILD_DEPENDS= sqlite3>=3.3.3:${PORTSDIR}/databases/sqlite3
+BUILD_DEPENDS= sqlite3>=3.3.3:${PORTSDIR}/databases/sqlite3 \
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -28,19 +29,9 @@ CONFIGURE_ARGS+= SQLITE_LOCATION=${LOCALBASE}
MAN3= DBD::SQLite.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-.else
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-.endif
-
post-patch:
${RM} -f ${WRKSRC}/getsqlite.pl
${PERL} -pi -e 's/\$$Config{d_usleep}/1/' ${WRKSRC}/Makefile.PL
${PERL} -pi -e '$$_="" if m|getsqlite.pl|' ${WRKSRC}/MANIFEST
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>