aboutsummaryrefslogtreecommitdiff
path: root/databases/pglogical/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/pglogical/Makefile')
-rw-r--r--databases/pglogical/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/databases/pglogical/Makefile b/databases/pglogical/Makefile
index 86bbf489446a..447a95078d21 100644
--- a/databases/pglogical/Makefile
+++ b/databases/pglogical/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pglogical
PORTVERSION= 1.1.2
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= http://packages.2ndquadrant.com/pglogical/tarballs/
@@ -23,6 +24,14 @@ OPTIONS_DEFINE= DOCS
DOCS_PORTDOCS= *
+.include <bsd.port.pre.mk>
+
+.if ${PGSQL_VER:M9.4}
+PLIST_SUB= PGSQL94=""
+.else
+PLIST_SUB= PGSQL94="@comment "
+.endif
+
# FFI
#TEST_DEPENDS= pg_regress:databases/postgresql${PGSQL_VER_NODOT}-pg_regress
#TEST_TARGET= do-test
@@ -30,6 +39,9 @@ DOCS_PORTDOCS= *
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/pglogical_create_subscriber
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/postgresql/pglogical.so
+.if ${PGSQL_VER:M9.4}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/pglogical_dump
+.endif
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@@ -38,4 +50,4 @@ post-install-DOCS-on:
#do-test:
# ${MAKE} ${MAKE_ARGS} check
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>