aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql-pltcl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/postgresql-pltcl/Makefile')
-rw-r--r--databases/postgresql-pltcl/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/databases/postgresql-pltcl/Makefile b/databases/postgresql-pltcl/Makefile
index b54b45ebb9b9..417b8f594592 100644
--- a/databases/postgresql-pltcl/Makefile
+++ b/databases/postgresql-pltcl/Makefile
@@ -10,11 +10,12 @@ CATEGORIES= databases tcl83
MAINTAINER= girgen@pingpong.net
+POSTGRESQL_PORT?= databases/postgresql7
POSTGRESQL_SUBPORT=YES
-.include <${.CURDIR}/../postgresql7/Makefile>
+.include <${PORTSDIR}/${POSTGRESQL_PORT}/Makefile>
LIB_DEPENDS= tcl${TCLVERSION:S/.//}:${PORTSDIR}/lang/tcl${TCLVERSION:S/.//}
-RUN_DEPENDS= postgres:${PORTSDIR}/databases/postgresql7
+RUN_DEPENDS= postgres:${PORTSDIR}/${POSTGRESQL_PORT}
# you can use "make TCLVERSION=8.4" or similar for your favourite tcl version
TCLVERSION?= 8.3