aboutsummaryrefslogtreecommitdiff
path: root/databases/postgresql12-contrib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/postgresql12-contrib/Makefile')
-rw-r--r--databases/postgresql12-contrib/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/databases/postgresql12-contrib/Makefile b/databases/postgresql12-contrib/Makefile
index 1c8dc612d65a..f7c88aa12cd4 100644
--- a/databases/postgresql12-contrib/Makefile
+++ b/databases/postgresql12-contrib/Makefile
@@ -8,9 +8,6 @@ CATEGORIES= databases
MAINTAINER= pgsql@FreeBSD.org
COMMENT= The contrib utilities from the PostgreSQL distribution
-LIB_DEPENDS= libxslt.so:textproc/libxslt \
- libxml2.so:textproc/libxml2
-
MASTERDIR= ${.CURDIR}/../postgresql12-server
USES= bison pgsql:12
@@ -20,17 +17,21 @@ INSTALL_DIRS= contrib
SLAVE_ONLY= yes
COMPONENT= -contrib
-CONFIGURE_ARGS= --with-libxslt --with-libxml --disable-nls --with-uuid=bsd
+CONFIGURE_ARGS= --disable-nls --with-uuid=bsd
LDFLAGS+= -lpthread -L${PREFIX}/lib
-OPTIONS_DEFINE= DOCS OPENSSL
-OPTIONS_DEFAULT=OPENSSL
+OPTIONS_DEFINE= DOCS OPENSSL XML
+OPTIONS_DEFAULT=OPENSSL XML
OPTIONS_SUB= yes
OPENSSL_DESC= Build with OpenSSL support
OPENSSL_USES= ssl
OPENSSL_CONFIGURE_WITH= openssl
+XML_CONFIGURE_WITH= libxslt libxml
+XML_LIB_DEPENDS=libxslt.so:textproc/libxslt \
+ libxml2.so:textproc/libxml2
+
post-configure:
@cd ${WRKSRC}/src/backend && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} symlinks