aboutsummaryrefslogtreecommitdiff
path: root/databases
diff options
context:
space:
mode:
Diffstat (limited to 'databases')
-rw-r--r--databases/hs-esqueleto/Makefile6
-rw-r--r--databases/hs-esqueleto/distinfo5
-rw-r--r--databases/hs-hedis/Makefile6
-rw-r--r--databases/hs-hedis/distinfo5
-rw-r--r--databases/hs-mysql/Makefile2
-rw-r--r--databases/hs-mysql/distinfo5
-rw-r--r--databases/hs-persistent-sqlite/Makefile8
-rw-r--r--databases/hs-persistent-sqlite/distinfo5
-rw-r--r--databases/hs-persistent-template/Makefile6
-rw-r--r--databases/hs-persistent-template/distinfo5
-rw-r--r--databases/hs-persistent-template/files/patch-persistent-template.cabal11
-rw-r--r--databases/hs-persistent/Makefile6
-rw-r--r--databases/hs-persistent/distinfo5
13 files changed, 46 insertions, 29 deletions
diff --git a/databases/hs-esqueleto/Makefile b/databases/hs-esqueleto/Makefile
index e2283ef17948..86407ac19b2f 100644
--- a/databases/hs-esqueleto/Makefile
+++ b/databases/hs-esqueleto/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= esqueleto
-PORTVERSION= 2.4.1
+PORTVERSION= 2.5.3
CATEGORIES= databases haskell
MAINTAINER= haskell@FreeBSD.org
@@ -9,8 +9,8 @@ COMMENT= Type-safe EDSL for SQL queries on persistent backends
LICENSE= BSD3CLAUSE
-USE_CABAL= blaze-html conduit>=1.1 monad-logger persistent>=2.1.1.7 \
- resourcet>=1.1 tagged>=0.2 text>=0.11 unordered-containers>=0.2
+USE_CABAL= blaze-html conduit monad-logger persistent \
+ resourcet tagged text unordered-containers
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/databases/hs-esqueleto/distinfo b/databases/hs-esqueleto/distinfo
index ef71a71d1a91..c40bdd28fc6a 100644
--- a/databases/hs-esqueleto/distinfo
+++ b/databases/hs-esqueleto/distinfo
@@ -1,2 +1,3 @@
-SHA256 (cabal/esqueleto-2.4.1.tar.gz) = 12cc83bd2774906c29df20be8b77d11e0fc6efedadf208714494dc406cd8f7fd
-SIZE (cabal/esqueleto-2.4.1.tar.gz) = 39113
+TIMESTAMP = 1499619928
+SHA256 (cabal/esqueleto-2.5.3.tar.gz) = 3d997551fe9e42b39b5eb8215d5daf4c59e33d55da5bc9eff193ae8a7f4ec482
+SIZE (cabal/esqueleto-2.5.3.tar.gz) = 40259
diff --git a/databases/hs-hedis/Makefile b/databases/hs-hedis/Makefile
index cd043fd6242e..7c8b4f5ece67 100644
--- a/databases/hs-hedis/Makefile
+++ b/databases/hs-hedis/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= hedis
-PORTVERSION= 0.6.9
+PORTVERSION= 0.9.8
CATEGORIES= databases haskell
MAINTAINER= haskell@FreeBSD.org
@@ -10,8 +10,8 @@ COMMENT= Client library for the Redis datastore
LICENSE= BSD3CLAUSE
-USE_CABAL= attoparsec>=0.12 BoundedChan>=1.0 bytestring-lexing>=0.5 \
- mtl>=2 network>=2 resource-pool>=0.2 vector>=0.9
+USE_CABAL= async bytestring-lexing mtl network resource-pool scanner stm \
+ text unordered-containers vector
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/databases/hs-hedis/distinfo b/databases/hs-hedis/distinfo
index 07042c46f016..45ae6d783f31 100644
--- a/databases/hs-hedis/distinfo
+++ b/databases/hs-hedis/distinfo
@@ -1,2 +1,3 @@
-SHA256 (cabal/hedis-0.6.9.tar.gz) = ead8c36dcb7093be9e414da900e2b6fa2f4bc8723a3a5346020d316c75e79179
-SIZE (cabal/hedis-0.6.9.tar.gz) = 27140
+TIMESTAMP = 1499619995
+SHA256 (cabal/hedis-0.9.8.tar.gz) = 822e298c2fe55f7edf0e3a005e901fe7b107c4734eb0dd8f1ab6382330d3ae62
+SIZE (cabal/hedis-0.9.8.tar.gz) = 40058
diff --git a/databases/hs-mysql/Makefile b/databases/hs-mysql/Makefile
index f26a3249b529..26bfc6400b69 100644
--- a/databases/hs-mysql/Makefile
+++ b/databases/hs-mysql/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mysql
-PORTVERSION= 0.1.1.8
+PORTVERSION= 0.1.4
CATEGORIES= databases haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/databases/hs-mysql/distinfo b/databases/hs-mysql/distinfo
index 7fdc00902e05..9df0cddfc532 100644
--- a/databases/hs-mysql/distinfo
+++ b/databases/hs-mysql/distinfo
@@ -1,2 +1,3 @@
-SHA256 (cabal/mysql-0.1.1.8.tar.gz) = 90f02af1c81e2189f65dcef0f78327eba4b0ef40bea5bde5cb74920727f9bd84
-SIZE (cabal/mysql-0.1.1.8.tar.gz) = 14092
+TIMESTAMP = 1499450806
+SHA256 (cabal/mysql-0.1.4.tar.gz) = 9b8675db208851524a77b6e5c4278e6bc29eab16d970a9dda312ae366bdb668e
+SIZE (cabal/mysql-0.1.4.tar.gz) = 16219
diff --git a/databases/hs-persistent-sqlite/Makefile b/databases/hs-persistent-sqlite/Makefile
index b13fb2fdcee8..1f54d0f1cf5a 100644
--- a/databases/hs-persistent-sqlite/Makefile
+++ b/databases/hs-persistent-sqlite/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= persistent-sqlite
-PORTVERSION= 2.2
+PORTVERSION= 2.6.2
CATEGORIES= databases haskell
MAINTAINER= haskell@FreeBSD.org
@@ -9,9 +9,9 @@ COMMENT= Backend for the persistent library using sqlite3
LICENSE= MIT
-USE_CABAL= aeson>=0.6.2 conduit>=0.5.3 monad-control>=0.2 \
- monad-logger>=0.2.4 persistent>=2.2 resourcet>=1.1 \
- text>=0.7
+USE_CABAL= aeson conduit microlens-th monad-control monad-logger \
+ old-locale persistent resource-pool resourcet text \
+ unordered-containers
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/databases/hs-persistent-sqlite/distinfo b/databases/hs-persistent-sqlite/distinfo
index 362c952802bc..18e946c2798a 100644
--- a/databases/hs-persistent-sqlite/distinfo
+++ b/databases/hs-persistent-sqlite/distinfo
@@ -1,2 +1,3 @@
-SHA256 (cabal/persistent-sqlite-2.2.tar.gz) = f11005a23df9ad0740111e675aab42f40eda7e37f4996ebae15e1fe48692c794
-SIZE (cabal/persistent-sqlite-2.2.tar.gz) = 1460775
+TIMESTAMP = 1499620122
+SHA256 (cabal/persistent-sqlite-2.6.2.tar.gz) = 6136c471fc81869cf0fde2049defb9c82698e3c0048d1321c3eda01046b985bf
+SIZE (cabal/persistent-sqlite-2.6.2.tar.gz) = 3568400
diff --git a/databases/hs-persistent-template/Makefile b/databases/hs-persistent-template/Makefile
index 3bb0f65abebc..2527c2d3ed3d 100644
--- a/databases/hs-persistent-template/Makefile
+++ b/databases/hs-persistent-template/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= persistent-template
-PORTVERSION= 2.1.3.4
+PORTVERSION= 2.5.2
CATEGORIES= databases haskell
MAINTAINER= haskell@FreeBSD.org
@@ -9,8 +9,8 @@ COMMENT= Type-safe, non-relational, multi-backend persistence
LICENSE= MIT
-USE_CABAL= aeson>=0.7 monad-control>=0.2 monad-logger path-pieces \
- persistent>=2.1.3 tagged text>=0.5 unordered-containers
+USE_CABAL= aeson aeson-compat http-api-data monad-control monad-logger \
+ path-pieces persistent tagged text unordered-containers
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/databases/hs-persistent-template/distinfo b/databases/hs-persistent-template/distinfo
index 69211f2d05a3..351c8ead4fb0 100644
--- a/databases/hs-persistent-template/distinfo
+++ b/databases/hs-persistent-template/distinfo
@@ -1,2 +1,3 @@
-SHA256 (cabal/persistent-template-2.1.3.4.tar.gz) = 4f28c9ef478e3835de5bc0105907582b2e0229cecc84ffa895c67c1a59ae2172
-SIZE (cabal/persistent-template-2.1.3.4.tar.gz) = 19084
+TIMESTAMP = 1499620138
+SHA256 (cabal/persistent-template-2.5.2.tar.gz) = de695b008158f9ae66d103fc33f89c098ebcf59337367063d9f4f816a58b4011
+SIZE (cabal/persistent-template-2.5.2.tar.gz) = 20403
diff --git a/databases/hs-persistent-template/files/patch-persistent-template.cabal b/databases/hs-persistent-template/files/patch-persistent-template.cabal
new file mode 100644
index 000000000000..9d1b31b66c25
--- /dev/null
+++ b/databases/hs-persistent-template/files/patch-persistent-template.cabal
@@ -0,0 +1,11 @@
+--- persistent-template.cabal.orig 2017-07-10 13:31:32 UTC
++++ persistent-template.cabal
+@@ -23,7 +23,7 @@ library
+ , text >= 0.5
+ , transformers >= 0.2 && < 0.6
+ , containers
+- , aeson >= 0.7 && < 1.2
++ , aeson >= 0.7 && < 1.3
+ , aeson-compat >= 0.3.2.0 && < 0.4
+ , monad-logger
+ , unordered-containers
diff --git a/databases/hs-persistent/Makefile b/databases/hs-persistent/Makefile
index 0df540ba667b..030f629d830b 100644
--- a/databases/hs-persistent/Makefile
+++ b/databases/hs-persistent/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= persistent
-PORTVERSION= 2.2
+PORTVERSION= 2.7.0
CATEGORIES= databases haskell
MAINTAINER= haskell@FreeBSD.org
@@ -11,8 +11,8 @@ LICENSE= MIT
USE_CABAL= aeson>=0.5 attoparsec base64-bytestring blaze-html>=0.5 \
blaze-markup>=0.5.1 conduit>=1.0 exceptions>=0.6 \
- fast-logger>=2.1 lifted-base>=0.1 monad-control>=0.3 \
- monad-logger>=0.3 mtl path-pieces>=0.1 resource-pool \
+ fast-logger>=2.1 http-api-data lifted-base>=0.1 monad-control>=0.3 \
+ monad-logger>=0.3 mtl old-locale path-pieces>=0.1 resource-pool \
resourcet>=1.1 scientific silently tagged text>=0.8 \
transformers-base unordered-containers vector
diff --git a/databases/hs-persistent/distinfo b/databases/hs-persistent/distinfo
index d76c723c69a4..2f8e6adf207d 100644
--- a/databases/hs-persistent/distinfo
+++ b/databases/hs-persistent/distinfo
@@ -1,2 +1,3 @@
-SHA256 (cabal/persistent-2.2.tar.gz) = 174047d7f140571081459713fbdeeabbd4a52bbc02dbf35969a0daec491a8512
-SIZE (cabal/persistent-2.2.tar.gz) = 43419
+TIMESTAMP = 1499620101
+SHA256 (cabal/persistent-2.7.0.tar.gz) = cebc4d51d362ce329cb29cb3873eacc01a1453c54d356c4115a7488543e3deea
+SIZE (cabal/persistent-2.7.0.tar.gz) = 69320