aboutsummaryrefslogtreecommitdiff
path: root/deskutils/babytrans/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/babytrans/Makefile')
-rw-r--r--deskutils/babytrans/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/deskutils/babytrans/Makefile b/deskutils/babytrans/Makefile
new file mode 100644
index 000000000000..cdf137106059
--- /dev/null
+++ b/deskutils/babytrans/Makefile
@@ -0,0 +1,38 @@
+# ex:ts=8
+# New ports collection makefile for: babytrans
+# Date created: 18 September 2002
+# Whom: Frederic Cambus
+#
+# $FreeBSD$
+#
+
+PORTNAME= babytrans
+PORTVERSION= 0.9.1
+CATEGORIES= deskutils
+MASTER_SITES= http://fjolliton.free.fr/babytrans/
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
+
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12 gnomehack gnomeprefix
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+USE_GMAKE= yes
+
+post-patch:
+.for file in de es fr pt_BR
+ @${REINPLACE_CMD} -e "s|CHARSET|ISO-8859-1|" \
+ -e "s|ENCODING|8bit|" ${WRKSRC}/po/${file}.po
+.endfor
+
+post-install:
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/config-file/dictionary ${DATADIR}
+ @${CAT} ${PKGMESSAGE} | ${SED} "s|%%DATADIR%%|${DATADIR}|"
+
+.include <bsd.port.mk>