aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gnome-font-viewer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/gnome-font-viewer/Makefile')
-rw-r--r--deskutils/gnome-font-viewer/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/deskutils/gnome-font-viewer/Makefile b/deskutils/gnome-font-viewer/Makefile
new file mode 100644
index 000000000000..05fbd90bb43b
--- /dev/null
+++ b/deskutils/gnome-font-viewer/Makefile
@@ -0,0 +1,28 @@
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
+# $FreeBSD$
+# $MCom: ports/trunk/deskutils/gnome-font-viewer/Makefile 19966 2014-10-16 06:32:52Z gusi $
+
+PORTNAME= gnome-font-viewer
+PORTVERSION= 3.14.0
+CATEGORIES= deskutils gnome
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome3
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GNOME 3 font viewer utility
+
+LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
+
+CONFLICTS= gnome-utils-2.[0-9]*
+
+USES= desktop-file-utils gettext gmake pathfix \
+ pkgconfig tar:xz
+USE_LDCONFIG= yes
+INSTALLS_ICONS= yes
+USE_GNOME= gnomeprefix intlhack gtk30 gnomedesktop3
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
+
+.include <bsd.port.mk>