aboutsummaryrefslogtreecommitdiff
path: root/deskutils/gnome-sound-recorder/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/gnome-sound-recorder/Makefile')
-rw-r--r--deskutils/gnome-sound-recorder/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/deskutils/gnome-sound-recorder/Makefile b/deskutils/gnome-sound-recorder/Makefile
new file mode 100644
index 000000000000..4fe928cb7915
--- /dev/null
+++ b/deskutils/gnome-sound-recorder/Makefile
@@ -0,0 +1,27 @@
+# Created by: Gustau Perez <gustau.perez@gmail.com>
+# $FreeBSD$
+# $MCom: ports/trunk/deskutils/gnome-sound-recorder/Makefile 19804 2014-08-13 14:55:11Z kwm $
+
+PORTNAME= gnome-sound-recorder
+PORTVERSION= 3.12.2
+PORTREVISION= 2
+CATEGORIES= deskutils gnome
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome3
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GNOME sound recorder application
+
+LIB_DEPENDS= libgjs.so:${PORTSDIR}/lang/gjs
+
+USES= gettext gmake libtool pathfix pkgconfig python:3 tar:xz
+USE_GNOME= gnomedesktop3 gnomeprefix gtk30 intlhack \
+ introspection:build
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+GLIB_SCHEMAS= org.gnome.gnome-sound-recorder.gschema.xml
+
+.include <bsd.port.mk>