aboutsummaryrefslogtreecommitdiff
path: root/deskutils/libgcal/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/libgcal/Makefile')
-rw-r--r--deskutils/libgcal/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/deskutils/libgcal/Makefile b/deskutils/libgcal/Makefile
index 9e812344b52b..bc59467da066 100644
--- a/deskutils/libgcal/Makefile
+++ b/deskutils/libgcal/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libgcal
-PORTVERSION= 0.9.3
-PORTREVISION= 1
+PORTVERSION= 0.9.5
CATEGORIES= deskutils
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
@@ -19,12 +18,15 @@ LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
xml2:${PORTSDIR}/textproc/libxml2
USE_BZIP2= yes
-GNU_CONFIGURE= yes
+USE_CMAKE= yes
+CMAKE_ARGS= -DCMAKE_INSTALL_PREFIX="${PREFIX}" \
+ -DLIB_INSTALL_DIR="${LOCALBASE}/lib" \
+ -DENABLE_TESTS=OFF
USE_LDCONFIG= yes
USE_GCC= 4.2+
post-patch:
@${REINPLACE_CMD} -e 's,(libdir)/pkgconfig,(prefix)/libdata/pkgconfig,' \
- ${WRKSRC}/Makefile.in
+ ${WRKSRC}/Makefile.am
.include <bsd.port.mk>