aboutsummaryrefslogtreecommitdiff
path: root/deskutils/libstreams/files
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/libstreams/files')
-rw-r--r--deskutils/libstreams/files/patch-libstreams__CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/deskutils/libstreams/files/patch-libstreams__CMakeLists.txt b/deskutils/libstreams/files/patch-libstreams__CMakeLists.txt
new file mode 100644
index 000000000000..652a79f97cfd
--- /dev/null
+++ b/deskutils/libstreams/files/patch-libstreams__CMakeLists.txt
@@ -0,0 +1,22 @@
+--- ./libstreams/CMakeLists.txt.orig 2013-02-05 21:34:57.000000000 +0000
++++ ./libstreams/CMakeLists.txt 2013-03-06 22:02:36.587664409 +0000
+@@ -46,9 +46,6 @@
+ # check for visibility support
+ macro_check_gcc_visibility(__STRIGI_HAVE_GCC_VISIBILITY)
+
+-# Generate include/strigi/strigiconfig.h and lib/config.h
+-include(ConfigureChecks.cmake)
+-
+ # check for required packages
+ find_package(ZLIB)
+ set_package_properties(ZLIB PROPERTIES
+@@ -75,6 +72,9 @@
+ TYPE REQUIRED
+ )
+
++# Generate include/strigi/strigiconfig.h and lib/config.h
++include(ConfigureChecks.cmake)
++
+ feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)
+
+ ##### building and testing #####