aboutsummaryrefslogtreecommitdiff
path: root/deskutils/py-khal/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/py-khal/Makefile')
-rw-r--r--deskutils/py-khal/Makefile35
1 files changed, 21 insertions, 14 deletions
diff --git a/deskutils/py-khal/Makefile b/deskutils/py-khal/Makefile
index a0f8740710fc..a8d8d30c0963 100644
--- a/deskutils/py-khal/Makefile
+++ b/deskutils/py-khal/Makefile
@@ -2,34 +2,41 @@
# $FreeBSD$
PORTNAME= khal
-PORTVERSION= 0.7.1
+DISTVERSION= 0.9.8
CATEGORIES= deskutils python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= che@bein.link
+MAINTAINER= lbdm@privacychain.ch
COMMENT= CalDAV-based calendar
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN= py36-khal-0.7.1 depends on package: py36-vdirsyncer<0.13 - not found
-
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>=3.2:devel/py-click@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}icalendar>=3.8.2:devel/py-icalendar@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}urwid>=1.2.1:devel/py-urwid@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}xdg>=0.25:devel/py-xdg@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytz>=2014.10,1:devel/py-pytz@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}dateutil>=2.3:devel/py-dateutil@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}configobj>=5.0.6:devel/py-configobj@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}tzlocal>=1.0:devel/py-tzlocal@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}vdirsyncer<0.13:deskutils/py-vdirsyncer@${FLAVOR} \
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>1.12.0:devel/py-setuptools_scm@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}atomicwrites>=0.1.7:devel/py-atomicwrites@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click>=3.2:devel/py-click@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}click-log>=0.2.0:devel/py-click-log@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}configobj>=0:devel/py-configobj@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>=0:devel/py-dateutil@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}icalendar>=3.11.7:devel/py-icalendar@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytz>=0:devel/py-pytz@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pkginfo>0:sysutils/py-pkginfo@${FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}tzlocal>=1.0:devel/py-tzlocal@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}urwid>=0:devel/py-urwid@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}vdirsyncer>=0:deskutils/py-vdirsyncer@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}xdg>=0:devel/py-xdg@${FLAVOR}
USES= python:3.4+
USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+OPTIONS_DEFINE= SETPROCTITLE
+
+SETPROCTITLE_DESC= Set the process title
+SETPROCTITLE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setproctitle>=0:devel/py-setproctitle@${FLAVOR}
+
PLIST_FILES= share/zsh/site-functions/__khal
post-install: