aboutsummaryrefslogtreecommitdiff
path: root/deskutils/py-taskw
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/py-taskw')
-rw-r--r--deskutils/py-taskw/Makefile27
-rw-r--r--deskutils/py-taskw/distinfo2
-rw-r--r--deskutils/py-taskw/files/patch-test__requirements.txt5
-rw-r--r--deskutils/py-taskw/pkg-descr12
4 files changed, 46 insertions, 0 deletions
diff --git a/deskutils/py-taskw/Makefile b/deskutils/py-taskw/Makefile
new file mode 100644
index 000000000000..8bf3bdf39c7a
--- /dev/null
+++ b/deskutils/py-taskw/Makefile
@@ -0,0 +1,27 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= taskw
+PORTVERSION= 1.0.3
+CATEGORIES= deskutils python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Bindings for your taskwarrior database
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:${PORTSDIR}/devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>0:${PORTSDIR}/devel/py-dateutil \
+ ${PYTHON_PKGNAMEPREFIX}pytz>0:${PORTSDIR}/devel/py-pytz
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:${PORTSDIR}/devel/py-nose
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+regression-test: build
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
+.include <bsd.port.mk>
diff --git a/deskutils/py-taskw/distinfo b/deskutils/py-taskw/distinfo
new file mode 100644
index 000000000000..a21fce961a87
--- /dev/null
+++ b/deskutils/py-taskw/distinfo
@@ -0,0 +1,2 @@
+SHA256 (taskw-1.0.3.tar.gz) = b640ec70fc0bbb4862589953488751b99509a9bd5480edf372f79a94ca5e47b9
+SIZE (taskw-1.0.3.tar.gz) = 38953
diff --git a/deskutils/py-taskw/files/patch-test__requirements.txt b/deskutils/py-taskw/files/patch-test__requirements.txt
new file mode 100644
index 000000000000..cc348c85072a
--- /dev/null
+++ b/deskutils/py-taskw/files/patch-test__requirements.txt
@@ -0,0 +1,5 @@
+--- test_requirements.txt.orig 2015-06-25 15:03:27 UTC
++++ test_requirements.txt
+@@ -1,2 +1 @@
+ nose>=1.3.4,<2
+-tox>=1.8.1,<2
diff --git a/deskutils/py-taskw/pkg-descr b/deskutils/py-taskw/pkg-descr
new file mode 100644
index 000000000000..443bbd877ba8
--- /dev/null
+++ b/deskutils/py-taskw/pkg-descr
@@ -0,0 +1,12 @@
+This is a python API for the taskwarrior command line tool.
+
+It contains two implementations: taskw.TaskWarriorShellout and
+taskw.TaskWarriorDirect. The first implementation is the supported one
+recommended by the upstream taskwarrior core project. It uses the task export
+and task import commands to manipulate the task database.
+
+The second implementation opens the task db file itself and directly
+manipulates it. It exists for backwards compatibility, but should only
+be used when necessary.
+
+WWW: https://github.com/ralphbean/taskw