aboutsummaryrefslogtreecommitdiff
path: root/devel/ace+tao
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ace+tao')
-rw-r--r--devel/ace+tao/Makefile3
-rw-r--r--devel/ace+tao/files/patch-av9
2 files changed, 9 insertions, 3 deletions
diff --git a/devel/ace+tao/Makefile b/devel/ace+tao/Makefile
index 80f960b6c89f..3eef9e38b92b 100644
--- a/devel/ace+tao/Makefile
+++ b/devel/ace+tao/Makefile
@@ -26,9 +26,6 @@ USE_GMAKE= yes
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
-# Code is not 64-bit clean yet
-ONLY_FOR_ARCHS= i386
-
TESTS= "@comment "
.if defined(WITH_TESTS)
USE_PERL5_BUILD= yes
diff --git a/devel/ace+tao/files/patch-av b/devel/ace+tao/files/patch-av
new file mode 100644
index 000000000000..c1ac4f288962
--- /dev/null
+++ b/devel/ace+tao/files/patch-av
@@ -0,0 +1,9 @@
+--- TAO/tao/Valuetype/ValueBase.inl.orig Sat Apr 4 12:25:24 1970
++++ TAO/tao/Valuetype/ValueBase.inl Thu Jan 20 09:27:52 2005
+@@ -67,5 +67,5 @@ TAO_OBV_GIOP_Flags::is_block_size (CORBA
+ ACE_INLINE CORBA::Boolean
+ TAO_OBV_GIOP_Flags::is_end_tag (CORBA::ULong tag)
+ {
+- return (0x80000000L < tag && tag <= 0xFFFFFFFFL);
++ return (0x80000000L < tag);
+ }