aboutsummaryrefslogtreecommitdiff
path: root/devel/cxref
diff options
context:
space:
mode:
Diffstat (limited to 'devel/cxref')
-rw-r--r--devel/cxref/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/devel/cxref/Makefile b/devel/cxref/Makefile
index 4c632963e7f9..763bc0c17366 100644
--- a/devel/cxref/Makefile
+++ b/devel/cxref/Makefile
@@ -13,18 +13,16 @@ COMMENT= C program cross-referencing & documentation tool
LICENSE= GPLv2
-USE_GMAKE= yes
+USES= gmake shebangfix
+SHEBANG_FILES= contrib/xrgr.pl
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-cxref-cpp
ALL_TARGET= programs
-MAN1= cxref.1 cxref-query.1
-
-NO_STAGE= yes
post-install:
- @${MKDIR} ${DATADIR}
- @${INSTALL_SCRIPT} ${WRKSRC}/contrib/*.pl ${DATADIR}
- @${INSTALL_DATA} ${WRKSRC}/contrib/*.el ${DATADIR}
- @${INSTALL_DATA} ${WRKSRC}/contrib/README* ${DATADIR}
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/contrib/*.pl ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/contrib/*.el ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/contrib/README* ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>