aboutsummaryrefslogtreecommitdiff
path: root/devel/dia2code/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/dia2code/Makefile')
-rw-r--r--devel/dia2code/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/devel/dia2code/Makefile b/devel/dia2code/Makefile
index 0f6d53b705b9..c34abe89220e 100644
--- a/devel/dia2code/Makefile
+++ b/devel/dia2code/Makefile
@@ -7,21 +7,21 @@
#
PORTNAME= dia2code
-PORTVERSION= 0.5
+PORTVERSION= 0.6
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ijliao@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= xml.5:${PORTSDIR}/textproc/libxml
+LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2 \
+ giconv:${PORTSDIR}/converters/libiconv
-USE_LIBTOOL= yes
-
-XML_CONFIG= ${LOCALBASE}/bin/xml-config
+GNU_CONFIGURE= yes
+XML_CONFIG= ${LOCALBASE}/bin/xml2-config
USE_GMAKE= yes
post-patch:
- @${PERL} -pi -e "s|%%XML_CONFIG%%|${XML_CONFIG}|g" ${WRKSRC}/dia2code/Makefile.in
+ @${PERL} -pi -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/dia2code/Makefile.in
.include <bsd.port.mk>