aboutsummaryrefslogtreecommitdiff
path: root/devel/gconf2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/gconf2/Makefile')
-rw-r--r--devel/gconf2/Makefile32
1 files changed, 26 insertions, 6 deletions
diff --git a/devel/gconf2/Makefile b/devel/gconf2/Makefile
index 4a56b29b8ed2..5fd580ee5ed2 100644
--- a/devel/gconf2/Makefile
+++ b/devel/gconf2/Makefile
@@ -3,13 +3,14 @@
# Whom: Ade Lovett <ade@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/devel/gconf2/Makefile,v 1.62 2005/11/03 18:43:02 mezz Exp $
#
PORTNAME= gconf2
-PORTVERSION= 2.10.1
+PORTVERSION= 2.12.1
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/GConf/2.10
+MASTER_SITE_SUBDIR= sources/GConf/2.12
DISTNAME= GConf-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -19,14 +20,33 @@ COMMENT= A configuration database system for GNOME
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomehier gnomehack orbit2 gtk20 libxml2 linc
+USE_GNOME= gnomehier gnomehack orbit2 gtk20 libxml2 linc ltverhack
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
--disable-gtk-doc
+# --enable-gconf-source=${PREFIX}/etc/gconf/schemas \
+
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-
MAN1= gconftool-2.1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_LDAP) || exists(${LOCALBASE}/include/ldap.h)
+USE_OPENLDAP= yes
+
+PLIST_SUB+= LDAP=""
+.else
+PLIST_SUB+= LDAP="@comment "
+.endif
+
+pre-everything::
+.if !defined(WITH_LDAP)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "You can enable ldap support by defining"
+ @${ECHO_MSG} "WITH_LDAP"
+ @${ECHO_MSG}
+.endif
+
+.include <bsd.port.post.mk>