aboutsummaryrefslogtreecommitdiff
path: root/devel/git-codereview/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/git-codereview/Makefile')
-rw-r--r--devel/git-codereview/Makefile16
1 files changed, 3 insertions, 13 deletions
diff --git a/devel/git-codereview/Makefile b/devel/git-codereview/Makefile
index 9c6b9fc4239b..4956e558c1e9 100644
--- a/devel/git-codereview/Makefile
+++ b/devel/git-codereview/Makefile
@@ -14,19 +14,9 @@ GH_ACCOUNT= golang
GH_PROJECT= review
GH_TAGNAME= 77ae237
-PLIST_FILES= bin/git-codereview
-
-post-patch:
- @${MKDIR} ${WRKSRC}/src/golang.org/x/review
-.for src in .gitattributes AUTHORS CONTRIBUTING.md CONTRIBUTORS LICENSE PATENTS \
- README codereview.cfg git-codereview
- @${MV} ${WRKSRC}/${src} ${WRKSRC}/src/golang.org/x/review
-.endfor
+GO_PKGNAME= golang.org/x/review
+GO_TARGET= ./git-codereview
-do-build:
- @cd ${WRKSRC}/src/golang.org/x/review ; ${SETENV} ${MAKE_ENV} ${BUILD_ENV} GOPATH=${WRKSRC} go install ./...
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+PLIST_FILES= bin/git-codereview
.include <bsd.port.mk>