aboutsummaryrefslogtreecommitdiff
path: root/devel/gnomevfs/files
diff options
context:
space:
mode:
Diffstat (limited to 'devel/gnomevfs/files')
-rw-r--r--devel/gnomevfs/files/patch-aa34
-rw-r--r--devel/gnomevfs/files/patch-ab16
-rw-r--r--devel/gnomevfs/files/patch-ac41
-rw-r--r--devel/gnomevfs/files/patch-libgnomevfs::gnome-vfs-mime.h13
-rw-r--r--devel/gnomevfs/files/patch-ltmain.sh22
5 files changed, 84 insertions, 42 deletions
diff --git a/devel/gnomevfs/files/patch-aa b/devel/gnomevfs/files/patch-aa
index 2b5bd53d4f03..961b472beec1 100644
--- a/devel/gnomevfs/files/patch-aa
+++ b/devel/gnomevfs/files/patch-aa
@@ -1,9 +1,9 @@
$FreeBSD$
---- configure.orig Wed Nov 7 13:37:59 2001
-+++ configure Wed Nov 7 13:38:44 2001
-@@ -5717,7 +5717,7 @@
+--- configure.orig Tue Jan 22 12:36:47 2002
++++ configure Tue Jan 22 12:38:07 2002
+@@ -5949,7 +5949,7 @@
VFS_GNOMEUI_LIBS="`gnome-config --libs gnome gnomeui`"
VFS_GNOMEGNORBA_LIBS="`gnome-config --libs gnome gnomeui gnorba`"
VFS_CAPPLET_LIBS="`gnome-config --libs gnome gnomeui capplet`"
@@ -12,18 +12,18 @@ $FreeBSD$
-@@ -9630,8 +9630,8 @@
+@@ -9854,8 +9854,8 @@
done
fi
-echo $ac_n "checking for bzCompressInit in -lbz2""... $ac_c" 1>&6
--echo "configure:9635: checking for bzCompressInit in -lbz2" >&5
+-echo "configure:9859: checking for bzCompressInit in -lbz2" >&5
+echo $ac_n "checking for BZ2_bzCompressInit in -lbz2""... $ac_c" 1>&6
-+echo "configure:9635: checking for BZ2_bzCompressInit in -lbz2" >&5
++echo "configure:9859: checking for BZ2_bzCompressInit in -lbz2" >&5
ac_lib_var=`echo bz2'_'bzCompressInit | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
-@@ -9644,10 +9644,10 @@
+@@ -9868,10 +9868,10 @@
/* Override any gcc2 internal prototype to avoid an error. */
/* We use char because int might match the return type of a gcc2
builtin and then its argument prototype would still apply. */
@@ -35,4 +35,22 @@ $FreeBSD$
+BZ2_bzCompressInit()
; return 0; }
EOF
- if { (eval echo configure:9654: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+ if { (eval echo configure:9878: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+@@ -10101,7 +10101,7 @@
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+
+- LDFLAGS="$LDFLAGS -L$with_openssl_libs -lssl -lcrypto -ldl"
++ LDFLAGS="$LDFLAGS -L$with_openssl_libs -lssl -lcrypto"
+ cat > conftest.$ac_ext <<EOF
+ #line 10107 "configure"
+ #include "confdefs.h"
+@@ -10135,7 +10135,7 @@
+ EOF
+
+ msg_openssl="yes"
+- OPENSSL_LDFLAGS="-L$with_openssl_libs -lssl -lcrypto -ldl"
++ OPENSSL_LDFLAGS="-L$with_openssl_libs -lssl -lcrypto"
+
+
+ if true; then
diff --git a/devel/gnomevfs/files/patch-ab b/devel/gnomevfs/files/patch-ab
index baeff1eceb82..5c79863db926 100644
--- a/devel/gnomevfs/files/patch-ab
+++ b/devel/gnomevfs/files/patch-ab
@@ -1,21 +1,21 @@
$FreeBSD$
---- Makefile.in.orig Fri Sep 28 11:17:29 2001
-+++ Makefile.in Fri Sep 28 11:22:06 2001
-@@ -177,9 +177,9 @@
+--- Makefile.in.orig Tue Jan 22 11:51:36 2002
++++ Makefile.in Tue Jan 22 11:53:19 2002
+@@ -186,9 +186,9 @@
+ cxxflags_set = @cxxflags_set@
l = @l@
- need_gnome_support = @need_gnome_support@
@PLATFORM_GNOME_2_TRUE@SUBDIRS_GNOME = doc
-@PLATFORM_GNOME_2_FALSE@SUBDIRS_GNOME = doc test
+@PLATFORM_GNOME_2_FALSE@SUBDIRS_GNOME = doc
--SUBDIRS = libgnomevfs libgnomevfs-pthread idl modules data man devel-docs $(SUBDIRS_GNOME) po
-+SUBDIRS = libgnomevfs libgnomevfs-pthread idl modules data man $(SUBDIRS_GNOME) po
+-SUBDIRS = libgnomevfs libgnomevfs-pthread idl modules man devel-docs $(SUBDIRS_GNOME) po
++SUBDIRS = libgnomevfs libgnomevfs-pthread idl modules man $(SUBDIRS_GNOME) po
EXTRA_DIST = HACKING TODO autogen.sh gnome-vfs.spec vfsConf.sh.in xml-i18n-extract.in xml-i18n-merge.in xml-i18n-update.in gnome-vfs-config.in
-@@ -187,7 +187,7 @@
+@@ -196,7 +196,7 @@
bin_SCRIPTS = $(top_builddir)/gnome-vfs-config
@@ -24,7 +24,7 @@ $FreeBSD$
confexec_DATA = vfsConf.sh
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
-@@ -526,11 +526,13 @@
+@@ -535,11 +535,13 @@
-e 's?\@VFS_INCLUDEDIR\@?$(VFS_INCLUDEDIR)?g' \
-e 's?\@VERSION\@?$(VERSION)?g' \
-e 's?\@VFS_LIBS\@?$(VFS_LIBS)?g' \
diff --git a/devel/gnomevfs/files/patch-ac b/devel/gnomevfs/files/patch-ac
index 01106d4b9978..781b2ec37bb8 100644
--- a/devel/gnomevfs/files/patch-ac
+++ b/devel/gnomevfs/files/patch-ac
@@ -1,15 +1,44 @@
---- modules/Makefile.in.orig Thu Nov 2 17:45:41 2000
-+++ modules/Makefile.in Fri Nov 3 10:52:23 2000
-@@ -235,2 +235,3 @@
+
+$FreeBSD$
+
+--- modules/Makefile.in.orig Tue Jan 22 12:42:11 2002
++++ modules/Makefile.in Tue Jan 22 13:13:11 2002
+@@ -197,7 +197,7 @@
+ @HAVE_CDDA_TRUE@CDDA_LTLIBS = libcdda.la
+ @HAVE_CDDA_FALSE@CDDA_LTLIBS =
-+libftp_la_LDFLAGS = $(module_flags)
+-module_flags = -export_dynamic -avoid-version
++module_flags = -export_dynamic -avoid-version -module
+ modulesdir = $(libdir)/vfs/modules
-@@ -283,3 +284,3 @@
+ modules_LTLIBRARIES = $(CDDA_LTLIBS) libextfs.la libfile.la libvfs-test.la $(HTTP_LTLIBS) libbzip2.la libgzip.la libftp.la libnntp.la libvfs-pipe.la libvfs-translate.la libdesktop.la $(NULL)
+@@ -216,7 +216,6 @@
+
+ libcdda_la_SOURCES = cdda-method.c cdda-method.h cdda-cddb.c cdda-cddb.h cdda-cdrom-extensions.h
+
+-
+ libcdda_la_LDFLAGS = $(module_flags)
+ libcdda_la_LIBADD = -L/gnome/lib -lcdda_paranoia -lcdda_interface
+
+@@ -311,7 +310,7 @@
+ libextfs_la_OBJECTS = extfs-method.lo
+ libfile_la_LIBADD =
libfile_la_OBJECTS = file-method.lo
-libvfs_test_la_LDFLAGS =
+libvfs_test_la_LDFLAGS = $(module_flags)
libvfs_test_la_DEPENDENCIES =
-@@ -292,3 +293,2 @@
+ libvfs_test_la_OBJECTS = test-method.lo
+ libhttp_la_DEPENDENCIES =
+@@ -320,10 +319,10 @@
+ libbzip2_la_OBJECTS = bzip2-method.lo
+ libgzip_la_DEPENDENCIES =
libgzip_la_OBJECTS = gzip-method.lo
-libftp_la_LDFLAGS =
++libftp_la_LDFLAGS = $(module_flags)
libftp_la_LIBADD =
+ libftp_la_OBJECTS = ftp-method.lo
+-libnntp_la_LDFLAGS =
++libnntp_la_LDFLAGS = $(module_flags)
+ libnntp_la_LIBADD =
+ libnntp_la_OBJECTS = nntp-method.lo
+ libvfs_pipe_la_DEPENDENCIES =
diff --git a/devel/gnomevfs/files/patch-libgnomevfs::gnome-vfs-mime.h b/devel/gnomevfs/files/patch-libgnomevfs::gnome-vfs-mime.h
deleted file mode 100644
index 5dcbb6b3b5e6..000000000000
--- a/devel/gnomevfs/files/patch-libgnomevfs::gnome-vfs-mime.h
+++ /dev/null
@@ -1,13 +0,0 @@
-
-$FreeBSD$
-
---- libgnomevfs/gnome-vfs-mime.h 2001/09/17 14:13:01 1.1
-+++ libgnomevfs/gnome-vfs-mime.h 2001/09/17 14:13:16
-@@ -27,6 +27,7 @@
- #include <ctype.h>
- #include <dirent.h>
- #include <libgnomevfs/gnome-vfs-uri.h>
-+#include <sys/types.h>
- #include <regex.h>
- #include <stdio.h>
- #include <string.h>
diff --git a/devel/gnomevfs/files/patch-ltmain.sh b/devel/gnomevfs/files/patch-ltmain.sh
index 98cb05e4ddb3..91c341790451 100644
--- a/devel/gnomevfs/files/patch-ltmain.sh
+++ b/devel/gnomevfs/files/patch-ltmain.sh
@@ -1,19 +1,27 @@
$FreeBSD$
---- ltmain.sh 2001/08/27 09:51:26 1.1
-+++ ltmain.sh 2001/08/27 09:51:42
-@@ -2408,6 +2408,9 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
+--- ltmain.sh.orig Sun Jan 20 16:11:07 2002
++++ ltmain.sh Tue Jan 22 13:34:20 2002
+@@ -1060,6 +1060,7 @@
+
+ -module)
+ module=yes
++ build_old_libs=no
+ continue
+ ;;
+
+@@ -2442,6 +2443,9 @@
+ *-*-openbsd*)
+ # Do not include libc due to us having libc/libc_r.
;;
+ *-*-freebsd*)
+ # FreeBSD doesn't need this...
+ ;;
*)
# Add libc to deplibs on all other systems if necessary.
- if test "$build_libtool_need_lc" = "yes"; then
-@@ -4175,10 +4178,12 @@
+ if test $build_libtool_need_lc = "yes"; then
+@@ -4208,10 +4212,12 @@
fi
# Install the pseudo-library for information purposes.