aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-cpphs
diff options
context:
space:
mode:
Diffstat (limited to 'devel/hs-cpphs')
-rw-r--r--devel/hs-cpphs/Makefile27
-rw-r--r--devel/hs-cpphs/distinfo2
-rw-r--r--devel/hs-cpphs/pkg-descr10
3 files changed, 39 insertions, 0 deletions
diff --git a/devel/hs-cpphs/Makefile b/devel/hs-cpphs/Makefile
new file mode 100644
index 000000000000..16dab8fb28c5
--- /dev/null
+++ b/devel/hs-cpphs/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: cpphs
+# Date created: 14 June 2004
+# Whom: obraun@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= cpphs
+PORTVERSION= 0.5
+CATEGORIES= devel haskell
+MASTER_SITES= http://www.cs.york.ac.uk/fp/cpphs/
+PKGNAMEPREFIX= hs-
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= A simplified re-implementation of cpp in Haskell
+
+BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
+
+PLIST_FILES= bin/cpphs
+
+do-build:
+ @(cd ${WRKSRC} && ghc -o cpphs --make cpphs)
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/cpphs ${PREFIX}/bin/cpphs
+
+.include <bsd.port.mk>
diff --git a/devel/hs-cpphs/distinfo b/devel/hs-cpphs/distinfo
new file mode 100644
index 000000000000..6e937783fb4b
--- /dev/null
+++ b/devel/hs-cpphs/distinfo
@@ -0,0 +1,2 @@
+MD5 (cpphs-0.5.tar.gz) = 33038f98da5604b95e439674bda77246
+SIZE (cpphs-0.5.tar.gz) = 32991
diff --git a/devel/hs-cpphs/pkg-descr b/devel/hs-cpphs/pkg-descr
new file mode 100644
index 000000000000..879cc1d606e8
--- /dev/null
+++ b/devel/hs-cpphs/pkg-descr
@@ -0,0 +1,10 @@
+cpphs is a simplified re-implementation of cpp, the C pre-processor, in
+Haskell.
+
+This version of the C pre-processor is pretty-much feature-complete, and
+compatible with the -traditional style. It has two modes:
+
+ * conditional compilation only (--nomacro),
+ * and full macro-expansion (default).
+
+WWW: http://www.cs.york.ac.uk/fp/cpphs/