aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-happy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/hs-happy/Makefile')
-rw-r--r--devel/hs-happy/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/devel/hs-happy/Makefile b/devel/hs-happy/Makefile
index 3a504b215c42..487e00358800 100644
--- a/devel/hs-happy/Makefile
+++ b/devel/hs-happy/Makefile
@@ -5,22 +5,30 @@
# $FreeBSD$
PORTNAME= happy
-PORTVERSION= 1.18.5
-PORTREVISION= 1
+PORTVERSION= 1.18.6
CATEGORIES= devel haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= An LALR(1) parser generator for the functional language Haskell
+LICENSE= BSD
+
+USE_CABAL= mtl
+
XMLDOCS= doc/happy:html
USE_AUTOTOOLS= autoconf:env
STANDALONE= yes
EXECUTABLE= happy
-PORTDATA= *
+USE_PERL5_BUILD= 5.8+
+
PORTEXAMPLES= *
INSTALL_PORTEXAMPLES= @(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+.if defined(SLAVE)
+GHC_CMD= ghc
+.endif
+
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>