aboutsummaryrefslogtreecommitdiff
path: root/devel/hs-haskell-language-server/Makefile.cabal.ghc94
diff options
context:
space:
mode:
Diffstat (limited to 'devel/hs-haskell-language-server/Makefile.cabal.ghc94')
-rw-r--r--devel/hs-haskell-language-server/Makefile.cabal.ghc94239
1 files changed, 106 insertions, 133 deletions
diff --git a/devel/hs-haskell-language-server/Makefile.cabal.ghc94 b/devel/hs-haskell-language-server/Makefile.cabal.ghc94
index 77789858f462..cd316742c4f4 100644
--- a/devel/hs-haskell-language-server/Makefile.cabal.ghc94
+++ b/devel/hs-haskell-language-server/Makefile.cabal.ghc94
@@ -1,102 +1,84 @@
-ghc94_USE_CABAL= Boolean-0.2.4_1 \
- Cabal-3.10.3.0 \
+ghc94_USE_CABAL= Cabal-3.10.3.0 \
Cabal-syntax-3.10.3.0 \
- Chart-1.9.5_2 \
- Chart-diagrams-1.9.5.1_2 \
Diff-0.5_1 \
Glob-0.10.2_3 \
- HsYAML-0.2.1.4_1 \
- HsYAML-aeson-0.2.0.1_10 \
- JuicyPixels-3.3.9 \
- ListLike-4.7.8.2 \
+ HsYAML-0.2.1.5 \
+ HsYAML-aeson-0.2.0.2 \
+ ListLike-4.7.8.3 \
MemoTrie-0.6.11 \
- MonadRandom-0.6_4 \
- NumInstances-1.4 \
+ MonadRandom-0.6.2 \
OneTuple-0.4.2_1 \
Only-0.1_2 \
- QuickCheck-2.15.0.1 \
- SVGFonts-1.8.0.1_2 \
+ QuickCheck-2.15.0.1_1 \
StateVar-1.2.2 \
- active-0.2.1_3 \
- adjunctions-4.4.2_2 \
- aeson-2.2.3.0_2 \
+ adjunctions-4.4.3 \
+ aeson-2.2.3.0_3 \
aeson-pretty-0.8.10 \
- alex-3.5.1.0 \
+ alex-3.5.2.0 \
algebraic-graphs-0.7_3 \
ansi-terminal-1.0.2 \
ansi-terminal-types-0.11.5_1 \
ansi-wl-pprint-0.6.9_4 \
- apply-refact-0.14.0.0 \
+ apply-refact-0.15.0.0 \
assoc-1.1.1_1 \
async-2.2.5_3 \
attoparsec-0.14.4_6 \
attoparsec-aeson-2.2.2.0 \
- base-compat-0.14.0 \
- base-orphans-0.9.2 \
+ base-compat-0.14.1 \
+ base-orphans-0.9.3 \
base16-bytestring-1.0.2.0_1 \
- base64-1.0_1 \
- base64-bytestring-1.2.1.0_1 \
- bifunctors-5.6.2_1 \
+ base64-1.0_2 \
+ bifunctors-5.6.2_2 \
+ binary-instances-1.0.6 \
binary-orphans-1.0.5_1 \
bitvec-1.1.5.0_3 \
blaze-builder-0.4.2.3 \
blaze-html-0.9.2.0_1 \
blaze-markup-0.8.3.0_2 \
- blaze-svg-0.3.7_3 \
blaze-textual-0.2.3.1 \
boring-0.2.2_1 \
- bytes-0.17.3_2 \
- cabal-doctest-1.0.9_3 \
+ cabal-add-0.1_2 \
+ cabal-install-parsers-0.6.1.1 \
call-stack-0.4.0 \
case-insensitive-1.2.1.0 \
cereal-0.5.8.3 \
- cereal-vector-0.2.0.1 \
character-ps-0.1 \
- charset-0.3.10_1 \
- circle-packing-0.1.0.6_4 \
+ charset-0.3.12 \
clay-0.15.0_2 \
clock-0.8.4 \
cmdargs-0.10.22 \
- co-log-core-0.3.2.2 \
+ co-log-core-0.3.2.5 \
colour-2.3.6 \
colourista-0.1.0.2_6 \
- commutative-semigroups-0.2.0.1 \
- comonad-5.0.8_2 \
- conduit-1.3.5 \
- conduit-extra-1.3.6 \
+ commutative-semigroups-0.2.0.2 \
+ comonad-5.0.9_1 \
+ conduit-1.3.6.1 \
+ conduit-extra-1.3.7 \
conduit-parse-0.2.1.1_1 \
constraints-0.14.2_1 \
- constraints-extras-0.4.0.1 \
+ constraints-extras-0.4.0.2 \
contravariant-1.5.5 \
cpphs-1.20.9.1_1 \
cryptohash-sha1-0.11.101.0_6 \
- cubicbezier-0.6.0.7 \
- data-default-0.7.1.1 \
- data-default-class-0.1.2.0 \
- data-default-instances-containers-0.0.1 \
- data-default-instances-dlist-0.0.1 \
- data-default-instances-old-locale-0.0.1 \
- data-fix-0.3.3 \
- deferred-folds-0.9.18.6 \
+ cryptohash-sha256-0.11.102.1_6 \
+ data-default-0.7.1.3 \
+ data-default-class-0.1.2.2 \
+ data-default-instances-containers-0.1.0.3 \
+ data-default-instances-dlist-0.0.1.2 \
+ data-default-instances-old-locale-0.0.1.2 \
+ data-fix-0.3.4_1 \
+ deferred-folds-0.9.18.7 \
dependent-map-0.4.0.0_2 \
dependent-sum-0.7.2.0_2 \
- deriving-aeson-0.2.9_1 \
- diagrams-contrib-1.4.5.1_2 \
- diagrams-core-1.5.1.1_2 \
- diagrams-lib-1.4.6.2_3 \
- diagrams-postscript-1.5.1.1_4 \
- diagrams-solve-0.1.3_3 \
- diagrams-svg-1.4.3.1_7 \
+ deriving-aeson-0.2.10 \
dir-traverse-0.2.3.0 \
direct-sqlite-2.3.29 \
distributive-0.6.2.1_1 \
dlist-1.0_2 \
- dual-tree-0.2.3.1_3 \
- enummapset-0.7.2.0_1 \
+ enummapset-0.7.3.0 \
extensions-0.1.0.1_1 \
- extra-1.7.16_1 \
+ extra-1.8 \
fail-4.9.0.0 \
- fast-math-1.0.2 \
file-embed-0.0.16.0 \
filemanip-0.3.6.3_1 \
filepattern-0.1.3 \
@@ -105,116 +87,109 @@ ghc94_USE_CABAL= Boolean-0.2.4_1 \
floskell-0.11.1 \
fmlist-0.9.4 \
focus-1.0.3.2 \
- foldable1-classes-compat-0.1_6 \
- foldl-1.4.16_1 \
- force-layout-0.4.0.6_13 \
+ foldable1-classes-compat-0.1.1_2 \
+ foldl-1.4.18_1 \
fourmolu-0.15.0.0_1 \
- free-5.2_6 \
- fsnotify-0.4.1.0_1 \
+ free-5.2_7 \
fuzzy-0.1.1.0 \
generic-arbitrary-1.0.1 \
- generic-deriving-1.14.5_3 \
+ generic-deriving-1.14.6_1 \
generic-lens-2.2.2.0_1 \
generic-lens-core-2.2.1.0_2 \
generically-0.1.1_4 \
ghc-exactprint-1.6.1.3 \
- ghc-lib-parser-9.8.2.20240223_1 \
+ ghc-lib-parser-9.8.5.20250214 \
ghc-lib-parser-ex-9.8.0.2 \
ghc-paths-0.1.0.12_7 \
ghc-trace-events-0.1.2.9 \
+ ghcide-2.10.0.0 \
githash-0.1.7.0 \
gitrev-1.3.1 \
- groups-0.5.3 \
haddock-library-1.11.0_5 \
- happy-1.20.1.1 \
- hashable-1.4.6.0 \
+ happy-2.1.5 \
+ happy-lib-2.1.5 \
+ hashable-1.4.7.0 \
haskell-src-exts-1.23.1 \
- heaps-0.4 \
- hie-bios-0.14.0_2 \
+ heaps-0.4.1 \
+ hie-bios-0.14.0_3 \
+ hie-compat-0.3.1.2_1 \
hiedb-0.6.0.1 \
hlint-3.8 \
- hsc2hs-0.68.10_3 \
+ hls-graph-2.10.0.0 \
+ hls-plugin-api-2.10.0.0 \
+ hls-test-utils-2.10.0.0 \
+ hsc2hs-0.68.10_4 \
hscolour-1.25 \
hw-fingertree-0.1.2.1_2 \
- hw-prim-0.6.3.2_2 \
+ hw-prim-0.6.3.2_3 \
implicit-hie-0.1.4.0 \
indexed-profunctors-0.1.1.1 \
indexed-traversable-0.1.4_1 \
indexed-traversable-instances-0.1.2_1 \
integer-conversion-0.1.1_1 \
- integer-logarithms-1.0.3.1_6 \
- integration-0.2.1 \
- intervals-0.9.2 \
- invariant-0.6.3 \
+ integer-logarithms-1.0.4 \
+ invariant-0.6.4_1 \
js-dgtable-0.5.2 \
js-flot-0.8.3 \
- js-jquery-3.3.1 \
- kan-extensions-5.2.6 \
- lens-5.2.3_5 \
+ js-jquery-3.7.1 \
+ kan-extensions-5.2.6_1 \
+ lens-5.3.4 \
lens-aeson-1.2.3_2 \
libyaml-0.1.4 \
libyaml-clib-0.2.5 \
- linear-1.22_3 \
list-t-1.0.5.7 \
- logict-0.8.1.0_1 \
- lsp-2.7.0.0_1 \
- lsp-test-0.17.1.0 \
- lsp-types-2.3.0.0 \
- lucid-2.11.20230408_2 \
- matrices-0.5.0 \
- megaparsec-9.6.1 \
- mfsolve-0.3.2.2 \
- microaeson-0.1.0.1_9 \
- microlens-0.4.13.1_1 \
- microlens-mtl-0.2.0.3_1 \
- microlens-th-0.4.3.15 \
+ logict-0.8.2.0 \
+ lsp-2.7.0.1 \
+ lsp-test-0.17.1.1 \
+ lsp-types-2.3.0.1 \
+ lucid-2.11.20250303 \
+ lukko-0.1.2_1 \
+ megaparsec-9.7.0 \
+ microaeson-0.1.0.2_1 \
mmap-0.5.9 \
mmorph-1.2.0_3 \
mod-0.2.0.1 \
monad-control-1.0.3.1 \
monad-dijkstra-0.1.1.5 \
- mono-traversable-1.0.17.0 \
- monoid-extras-0.6.2_3 \
- monoid-subclasses-1.2.5.1 \
- mtl-compat-0.2.2 \
+ mono-traversable-1.0.21.0 \
+ monoid-subclasses-1.2.6 \
neat-interpolation-0.5.1.4 \
- network-3.2.0.0 \
+ network-3.2.7.0 \
network-uri-2.6.4.2_1 \
newtype-generics-0.6.2_4 \
old-locale-1.0.0.7_2 \
old-time-1.1.0.4 \
opentelemetry-0.8.0 \
- operational-0.2.4.2_1 \
optparse-applicative-0.17.1.0_1 \
optparse-simple-0.1.1.4 \
ordered-containers-0.2.4 \
ormolu-0.7.4.0_5 \
- os-string-2.0.3 \
+ os-string-2.0.7 \
parallel-3.2.2.0_9 \
parser-combinators-1.3.0_1 \
- parsers-0.12.11_3 \
+ parsers-0.12.12_1 \
polyparse-1.13_9 \
- pretty-simple-4.1.2.0 \
+ pretty-simple-4.1.3.0 \
prettyprinter-1.7.1 \
prettyprinter-ansi-terminal-1.1.3 \
primes-0.2.1.0 \
- primitive-0.9.0.0_2 \
- primitive-extras-0.10.2 \
- primitive-unlifted-2.1.0.0_1 \
+ primitive-0.9.1.0 \
+ primitive-extras-0.10.2.2 \
+ primitive-unlifted-2.2.0.0 \
process-extras-0.7.4_1 \
profunctors-5.6.2_3 \
- psqueues-0.2.8.0_1 \
- quickcheck-instances-0.3.31_2 \
- random-1.2.1.2 \
+ psqueues-0.2.8.1 \
+ quickcheck-instances-0.3.32_1 \
+ random-1.3.0 \
random-shuffle-0.0.4 \
refact-0.3.0.2 \
- reflection-2.1.8 \
+ reflection-2.1.9_1 \
regex-1.1.0.2 \
regex-applicative-0.3.4 \
- regex-base-0.94.0.2_4 \
+ regex-base-0.94.0.3 \
regex-pcre-builtin-0.95.2.3.8.44_6 \
- regex-tdfa-1.3.2.2_3 \
- relude-1.2.1.0_3 \
+ regex-tdfa-1.3.2.3 \
+ relude-1.2.2.0_4 \
resourcet-1.3.0 \
retrie-1.2.3 \
row-types-1.0.1.2_1 \
@@ -223,41 +198,40 @@ ghc94_USE_CABAL= Boolean-0.2.4_1 \
scientific-0.3.8.0_2 \
selective-0.7.0.1 \
semialign-1.3.1_2 \
- semigroupoids-6.0.1_1 \
+ semigroupoids-6.0.1_2 \
semigroups-0.20 \
semirings-0.7 \
shake-0.19.8 \
slist-0.2.1.0_1 \
some-1.0.6_2 \
- sorted-list-0.2.2.0 \
+ sorted-list-0.2.3.1 \
split-0.2.5 \
- splitmix-0.1.0.5_1 \
+ splitmix-0.1.1 \
sqlite-simple-0.4.19.0 \
- stan-0.1.3.0 \
- statestack-0.3.1.1_3 \
- stm-containers-1.2.1 \
- stm-hamt-1.2.1 \
- streaming-commons-0.2.2.6_1 \
- strict-0.5_1 \
+ stan-0.2.0.0 \
+ stm-containers-1.2.1.1 \
+ stm-hamt-1.2.1.1 \
+ streaming-commons-0.2.3.0 \
+ strict-0.5.1_1 \
stylish-haskell-0.14.6.0 \
- svg-builder-0.1.1_10 \
syb-0.7.2.4 \
- tagged-0.8.8_1 \
- tasty-1.5_2 \
+ tagged-0.8.9 \
+ tar-0.6.3.0_1 \
+ tasty-1.5.3_1 \
tasty-expected-failure-0.12.3 \
tasty-golden-2.3.5 \
- tasty-hunit-0.10.1 \
- tasty-rerun-1.1.19_4 \
+ tasty-hunit-0.10.2 \
+ tasty-rerun-1.1.20 \
temporary-1.3 \
terminal-size-0.3.4_1 \
- text-iso8601-0.1.1_1 \
- text-rope-0.2 \
+ text-iso8601-0.1.1_2 \
+ text-rope-0.3 \
text-short-0.1.6_3 \
- th-abstraction-0.7.0.0 \
- th-compat-0.1.5_2 \
+ th-abstraction-0.7.1.0_1 \
+ th-compat-0.1.6 \
th-env-0.1.1 \
these-1.2.1_2 \
- time-compat-1.9.7_2 \
+ time-compat-1.9.8 \
time-locale-compat-0.1.1.5 \
tomland-1.3.3.3_2 \
transformers-base-0.4.6 \
@@ -265,22 +239,21 @@ ghc94_USE_CABAL= Boolean-0.2.4_1 \
trial-0.0.0.0_5 \
trial-optparse-applicative-0.0.0.0_4 \
trial-tomland-0.0.0.0_5 \
- typed-process-0.2.11.1 \
+ typed-process-0.2.12.0 \
unbounded-delays-0.1.1.1 \
uniplate-1.6.13_1 \
- unix-compat-0.7.1 \
- unliftio-0.2.25.0 \
+ unix-compat-0.7.4 \
+ unliftio-0.2.25.1 \
unliftio-core-0.2.1.0_4 \
unordered-containers-0.2.20_4 \
utf8-string-1.0.2 \
- uuid-types-1.0.6_2 \
+ uuid-types-1.0.6_3 \
validation-selective-0.2.0.0_5 \
- vector-0.13.1.0_2 \
- vector-algorithms-0.9.0.2_1 \
- vector-space-0.16 \
+ vector-0.13.2.0_1 \
+ vector-algorithms-0.9.1.0 \
+ vector-binary-instances-0.2.5.2_5 \
vector-stream-0.1.0.1_3 \
void-0.7.3 \
witherable-0.5_1 \
- xml-1.3.14_2 \
yaml-0.11.11.2_2 \
zlib-0.7.1.0_2