aboutsummaryrefslogtreecommitdiff
path: root/devel/libglademm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libglademm/Makefile')
-rw-r--r--devel/libglademm/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/devel/libglademm/Makefile b/devel/libglademm/Makefile
new file mode 100644
index 000000000000..fd14174ae148
--- /dev/null
+++ b/devel/libglademm/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: libglademm
+# Date created: 22 May 2003
+# Whom: Alexander Nedotsukov <bland@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libglademm
+PORTVERSION= 2.0.1
+CATEGORIES= devel gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gtkmm
+DIST_SUBDIR= gnome2
+
+MAINTAINER= bland@mail.ru
+COMMENT= C++ wrapper for libglade2 library
+
+LIB_DEPENDS= gtkmm-2.0:${PORTSDIR}/x11-toolkits/gtk--2
+BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= libglade2
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --enable-static
+
+.include <bsd.port.mk>