aboutsummaryrefslogtreecommitdiff
path: root/devel/libvhdi/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libvhdi/Makefile')
-rw-r--r--devel/libvhdi/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/devel/libvhdi/Makefile b/devel/libvhdi/Makefile
index 1ff17b039ddf..cc27858f7687 100644
--- a/devel/libvhdi/Makefile
+++ b/devel/libvhdi/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= libvhdi
-PORTVERSION= 20160424
+PORTVERSION= 20170223
DISTVERSIONPREFIX= alpha-
CATEGORIES= devel
MASTER_SITES= https://github.com/libyal/libvhdi/releases/download/${PORTVERSION}/ \
@@ -12,19 +12,24 @@ MAINTAINER= antoine@FreeBSD.org
COMMENT= Library and tools to access the Virtual Hard Disk image format
LICENSE= LGPL3+
+LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-python --with-libintl-prefix=${LOCALBASE}
-USES= fuse gettext libtool pathfix pkgconfig python
+CONFIGURE_ARGS= --enable-python
+USES= fuse libtool pathfix pkgconfig python
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-PORTDOCS= AUTHORS ChangeLog
+OPTIONS_DEFINE= DOCS NLS
+
+NLS_USES= gettext
+NLS_CONFIGURE_ON= --with-libintl-prefix=${LOCALBASE}
+NLS_CONFIGURE_OFF= --disable-nls
-OPTIONS_DEFINE= DOCS
+PORTDOCS= AUTHORS ChangeLog
-post-install-DOCS-on:
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}