aboutsummaryrefslogtreecommitdiff
path: root/devel/ncnf
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ncnf')
-rw-r--r--devel/ncnf/Makefile28
-rw-r--r--devel/ncnf/distinfo2
-rw-r--r--devel/ncnf/pkg-descr9
-rw-r--r--devel/ncnf/pkg-plist15
4 files changed, 54 insertions, 0 deletions
diff --git a/devel/ncnf/Makefile b/devel/ncnf/Makefile
new file mode 100644
index 000000000000..f7a1d60a5f86
--- /dev/null
+++ b/devel/ncnf/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: ncnf
+# Date created: 29 May 2005
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ncnf
+PORTVERSION= 3.0.1
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Generic configuration management library
+
+LIB_DEPENDS= strfunc.7:${PORTSDIR}/devel/libstrfunc
+
+INSTALLS_SHLIB= YES
+USE_LIBTOOL_VER=15
+USE_REINPLACE= YES
+
+post-patch:
+.ifdef NOPORTDOCS
+ @${REINPLACE_CMD} -e '/^SUBDIRS =/s/doc//' ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ncnf/distinfo b/devel/ncnf/distinfo
new file mode 100644
index 000000000000..566a44341984
--- /dev/null
+++ b/devel/ncnf/distinfo
@@ -0,0 +1,2 @@
+MD5 (ncnf-3.0.1.tar.gz) = e17079055af175f0e5da4bc72b9902b7
+SIZE (ncnf-3.0.1.tar.gz) = 392291
diff --git a/devel/ncnf/pkg-descr b/devel/ncnf/pkg-descr
new file mode 100644
index 000000000000..4b4385be74d6
--- /dev/null
+++ b/devel/ncnf/pkg-descr
@@ -0,0 +1,9 @@
+Netli Configuration library (NCNF) is the module for C applications to
+efficiently read and use the configuration file contents. NCNF converts
+the on-disk configuration file structure to the memory-based tree of
+configuration objects. Basic NCNF API does not make a distinction
+between different types of configuration objects. However, there are a
+couple of additional functions present to ease the use of certain types
+of configuration objects.
+
+WWW: http://sourceforge.net/projects/ncnf
diff --git a/devel/ncnf/pkg-plist b/devel/ncnf/pkg-plist
new file mode 100644
index 000000000000..bca375901d3e
--- /dev/null
+++ b/devel/ncnf/pkg-plist
@@ -0,0 +1,15 @@
+include/ncnf.h
+include/ncnf_app.h
+include/ncnf_coll.h
+include/ncnf_int.h
+include/ncnf_walk.h
+include/ncnf_diff.h
+include/ncnf_notif.h
+include/ncnf_constr.h
+include/ncnf_ql.h
+lib/libncnf.a
+lib/libncnf.so
+lib/libncnf.so.3
+%%PORTDOCS%%%%DOCSDIR%%/ncnf-validator-syntax.txt
+%%PORTDOCS%%%%DOCSDIR%%/ncnf-whitepaper.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%