aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Test-WWW-Selenium/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Test-WWW-Selenium/Makefile')
-rw-r--r--devel/p5-Test-WWW-Selenium/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/devel/p5-Test-WWW-Selenium/Makefile b/devel/p5-Test-WWW-Selenium/Makefile
new file mode 100644
index 000000000000..c418248d0353
--- /dev/null
+++ b/devel/p5-Test-WWW-Selenium/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: devel/p5-Test-WWW-Selenium
+# Date created: 12 June, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-WWW-Selenium
+PORTVERSION= 1.17
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Perl driver and test library for Selenium Remote Control (SRC)
+
+BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-Test-Mock-LWP>=0:${PORTSDIR}/devel/p5-Test-Mock-LWP \
+ p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::WWW::Selenium.3 \
+ WWW::Selenium::Util.3 \
+ WWW::Selenium.3
+
+.include <bsd.port.mk>