aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Tie-Restore/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/p5-Tie-Restore/Makefile')
-rw-r--r--devel/p5-Tie-Restore/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/devel/p5-Tie-Restore/Makefile b/devel/p5-Tie-Restore/Makefile
new file mode 100644
index 000000000000..e594791f95df
--- /dev/null
+++ b/devel/p5-Tie-Restore/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Tie-Restore
+# Date created: April 19th 2006
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tie-Restore
+PORTVERSION= 0.11
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Tie
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= Restores ties to an existing object
+
+PERL_CONFIGURE= yes
+
+MAN3= Tie::Restore.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ ${PERL} -pi -e 's/^our (\S+)/use vars qw($$1); $$1/' ${WRKSRC}/Restore.pm
+.endif
+
+.include <bsd.port.post.mk>