aboutsummaryrefslogtreecommitdiff
path: root/devel/pear-SebastianBergmann_PHPCPD/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/pear-SebastianBergmann_PHPCPD/Makefile')
-rw-r--r--devel/pear-SebastianBergmann_PHPCPD/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/devel/pear-SebastianBergmann_PHPCPD/Makefile b/devel/pear-SebastianBergmann_PHPCPD/Makefile
index b2885257776f..4900c3498536 100644
--- a/devel/pear-SebastianBergmann_PHPCPD/Makefile
+++ b/devel/pear-SebastianBergmann_PHPCPD/Makefile
@@ -4,7 +4,7 @@
PORTNAME= PHPCPD
DISTVERSION= 2.0.0
CATEGORIES= devel pear
-PKGNAMEPREFIX= pear-SebastianBergmann_
+PKGNAMEPREFIX= ${PEAR_PKGNAMEPREFIX}SebastianBergmann_
MAINTAINER= joneum@FreeBSD.org
COMMENT= Copy/Paste Detector (CPD) for PHP code
@@ -12,16 +12,15 @@ COMMENT= Copy/Paste Detector (CPD) for PHP code
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= pear-ezc_ConsoleTools>=1.6.1:devel/pear-ezc_ConsoleTools \
- pear-SebastianBergmann_FinderFacade>=1.2.2:devel/pear-SebastianBergmann_FinderFacade \
- pear-PHP_Timer>=1.0.9:devel/pear-PHP_Timer \
- pear-channel-phpunit>=20110327:devel/pear-channel-phpunit
-RUN_DEPENDS= pear-ezc_ConsoleTools>=1.6.1:devel/pear-ezc_ConsoleTools \
- pear-SebastianBergmann_FinderFacade>=1.2.2:devel/pear-SebastianBergmann_FinderFacade \
- pear-PHP_Timer>=1.0.9:devel/pear-PHP_Timer \
- pear-channel-phpunit>=20110327:devel/pear-channel-phpunit
+BUILD_DEPENDS= ${PEAR_PKGNAMEPREFIX}ezc_ConsoleTools>=1.6.1:devel/pear-ezc_ConsoleTools@${PHP_FLAVOR} \
+ ${PEAR_PKGNAMEPREFIX}SebastianBergmann_FinderFacade>=1.2.2:devel/pear-SebastianBergmann_FinderFacade@${PHP_FLAVOR} \
+ ${PEAR_PKGNAMEPREFIX}PHP_Timer>=1.0.9:devel/pear-PHP_Timer@${PHP_FLAVOR}
+RUN_DEPENDS= ${PEAR_PKGNAMEPREFIX}ezc_ConsoleTools>=1.6.1:devel/pear-ezc_ConsoleTools@${PHP_FLAVOR} \
+ ${PEAR_PKGNAMEPREFIX}SebastianBergmann_FinderFacade>=1.2.2:devel/pear-SebastianBergmann_FinderFacade@${PHP_FLAVOR} \
+ ${PEAR_PKGNAMEPREFIX}PHP_Timer>=1.0.9:devel/pear-PHP_Timer@${PHP_FLAVOR}
-USES= php
+USES= php pear:env
+PEAR_CHANNEL= phpunit
USE_GITHUB= yes
GH_ACCOUNT= sebastianbergmann
GH_PROJECT= ${PORTNAME:tl}