aboutsummaryrefslogtreecommitdiff
path: root/devel/py-ro/files/patch-setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-ro/files/patch-setup.py')
-rw-r--r--devel/py-ro/files/patch-setup.py20
1 files changed, 20 insertions, 0 deletions
diff --git a/devel/py-ro/files/patch-setup.py b/devel/py-ro/files/patch-setup.py
new file mode 100644
index 000000000000..4df14536d6ef
--- /dev/null
+++ b/devel/py-ro/files/patch-setup.py
@@ -0,0 +1,20 @@
+--- setup.py.orig Fri Mar 22 18:04:34 2002
++++ setup.py Fri Mar 22 18:11:18 2002
+@@ -36,16 +36,11 @@
+ else:
+ # first, confirm the installation path of the scripts.
+ scripts=[]
+- scr=raw_input('Do you want the Pyro scripts (in bin/) installed (y/n)? ')
++ scr='y'
+ if scr.lower()=='y':
+ cp=ConfigParser()
+ cp.read('setup.cfg')
+ loc=cp.get('install','install-scripts')
+- print 'Some Pyro scripts may conflict with system tools already on your system.'
+- print 'Choose your script install directory carefully.'
+- scr=raw_input('Where do you want them to be installed ('+loc+')? ')
+- if scr:
+- loc=scr
+ cp.set('install','install-scripts',loc)
+ cp.write(open('setup.cfg','w'))
+