aboutsummaryrefslogtreecommitdiff
path: root/devel/qt4-assistant-adp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/qt4-assistant-adp/Makefile')
-rw-r--r--devel/qt4-assistant-adp/Makefile31
1 files changed, 17 insertions, 14 deletions
diff --git a/devel/qt4-assistant-adp/Makefile b/devel/qt4-assistant-adp/Makefile
index 332e4bdfe561..f9fe3e889a97 100644
--- a/devel/qt4-assistant-adp/Makefile
+++ b/devel/qt4-assistant-adp/Makefile
@@ -9,7 +9,7 @@ PORTNAME= assistant
PORTVERSION= ${QT4_VERSION}
CATEGORIES?= devel
PKGNAMEPREFIX= qt4-
-PKGNAMESUFFIX= -adp
+PKGNAMESUFFIX= -adp
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt documentation browser, adp compat version
@@ -29,25 +29,28 @@ MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib \
PATH=${WRKSRC}/bin:$$PATH
DO_NOT_EXTRACT= demos doc examples mkspecs qmake translations \
- src/opengl src/phonon \
- src/qt3support src/script src/sql src/svg src/testlib \
- src/tools src/xmlpatterns src/3rdparty/clucene \
- src/3rdparty/kdebase src/3rdparty/kdelibs src/3rdparty/webkit
+ src/activeqt src/multimedia src/opengl src/openvg src/phonon \
+ src/qt3support src/s60installs src/s60main src/script \
+ src/scripttools src/sql src/svg src/testlib src/tools \
+ src/winmain src/xmlpatterns src/3rdparty/clucene \
+ src/3rdparty/freetype src/3rdparty/libjpeg src/3rdparty/libmng \
+ src/3rdparty/libpng src/3rdparty/libtiff src/3rdparty/phonon \
+ src/3rdparty/webkit
EXTRACT_AFTER_ARGS= | ${TAR} -xf -
.for dne in ${DO_NOT_EXTRACT}
EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
.endfor
-WRKSRC=${WRKDIR}/${DISTNAME}/tools/${PORTNAME}/compat
-CONFIGURE_WRKSRC=${WRKSRC}/../../../
-PATCH_WRKSRC=${CONFIGURE_WRKSRC}
+BUILD_WRKSRC= ${WRKSRC}/tools/${PORTNAME}/compat
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+EXTRA_PATCHES= ${.CURDIR}/../../devel/qt4/files/patch-configure
pre-configure:
- ${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
- ${MKDIR} ${WRKSRC}/../../../mkspecs
- ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/../../../bin/qmake
- ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/../../../bin/moc
- ${LN} -sf ${LOCALBASE}/bin/uic-qt4 ${WRKSRC}/../../../bin/uic
- ${LN} -sf ${LOCALBASE}/bin/rcc ${WRKSRC}/../../../bin/rcc
+ ${MKDIR} ${WRKSRC}/mkspecs
+ ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/bin/qmake
+ ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/bin/moc
+ ${LN} -sf ${LOCALBASE}/bin/uic-qt4 ${WRKSRC}/bin/uic
+ ${LN} -sf ${LOCALBASE}/bin/rcc ${WRKSRC}/bin/rcc
.include <bsd.port.mk>