aboutsummaryrefslogtreecommitdiff
path: root/devel/valgrind-snapshot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/valgrind-snapshot/Makefile')
-rw-r--r--devel/valgrind-snapshot/Makefile25
1 files changed, 16 insertions, 9 deletions
diff --git a/devel/valgrind-snapshot/Makefile b/devel/valgrind-snapshot/Makefile
index 2118d841834c..9e280c1ba946 100644
--- a/devel/valgrind-snapshot/Makefile
+++ b/devel/valgrind-snapshot/Makefile
@@ -52,15 +52,20 @@ pre-everything::
@${ECHO_CMD} ""
@${ECHO_CMD} "Check if procfs is running: YES"
.else
- @${ECHO_CMD} "-----------------------------------------------------------"
- @${ECHO_CMD} ""
- @${ECHO_CMD} "Valgrind needs a running procfs, which is not"
- @${ECHO_CMD} "activated on your system. Please read the procfs\(5\)"
- @${ECHO_CMD} "manpage and add the following line to /etc/fstab:"
- @${ECHO_CMD} ""
- @${ECHO_CMD} "proc /proc procfs rw 0 0"
- @${ECHO_CMD} ""
- @${ECHO_CMD} "-----------------------------------------------------------"
+#
+# /proc is not mounted on the machine in the package building cluster that
+# that builds the list of IGNOREd ports (but it is on the build machines),
+# so we need to make an exception here.
+#
+.ifndef (PACKAGE_BUILDING)
+ECHO_MSG=/usr/bin/printf
+IGNORE= needs a running procfs, which is not\n\
+\ \ \ \ \ activated on your system. Please read the procfs\(5\)\n\
+\ \ \ \ \ man page and add the following line to /etc/fstab:\n\
+\n\
+\ \ \ \ \ proc /proc procfs rw 0 0\n\
+\n
+.endif
.endif
pre-patch:
@@ -84,11 +89,13 @@ post-install:
.endif
# Generate suppression files
+.ifndef (PACKAGE_BUILDING)
@yes | ${PREFIX}/bin/valgrind --tool=memcheck --gen-suppressions=yes true 2>&1 \
| ${SED} -e 's,.*{$$,{,' \
| ${GREP} -v '^=' \
> ${WRKDIR}/freebsd-default.supp || \
${RM} ${WRKDIR}/freebsd-default.supp
+.endif
.if exists(${WRKDIR}/freebsd-default.supp)
@${INSTALL_DATA} ${WRKDIR}/freebsd-default.supp \