aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/qgit/Makefile2
-rw-r--r--devel/qgit/files/patch-src_git.cpp24
2 files changed, 25 insertions, 1 deletions
diff --git a/devel/qgit/Makefile b/devel/qgit/Makefile
index c271a171856c..400abc6061a8 100644
--- a/devel/qgit/Makefile
+++ b/devel/qgit/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qgit
PORTVERSION= 2.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}4/${PORTVERSION}
PKGNAMESUFFIX= -qt4
diff --git a/devel/qgit/files/patch-src_git.cpp b/devel/qgit/files/patch-src_git.cpp
new file mode 100644
index 000000000000..29cd5949b654
--- /dev/null
+++ b/devel/qgit/files/patch-src_git.cpp
@@ -0,0 +1,24 @@
+repo-config was aliased to config as of git 1.7 (2010)
+and was removed, it seems, in 1.8.5 (2012). None of those
+git versions are still supported upstream; switch to git config.
+
+--- src/git.cpp.orig 2009-03-12 17:14:31 UTC
++++ src/git.cpp
+@@ -425,7 +425,7 @@ void Git::setTextCodec(QTextCodec* tc) {
+ if (name == "Big5-HKSCS")
+ name = "Big5";
+
+- run("git repo-config i18n.commitencoding " + name);
++ run("git config i18n.commitencoding " + name);
+ }
+
+ QTextCodec* Git::getTextCodec(bool* isGitArchive) {
+@@ -435,7 +435,7 @@ QTextCodec* Git::getTextCodec(bool* isGi
+ return NULL;
+
+ QString runOutput;
+- if (!run("git repo-config --get i18n.commitencoding", &runOutput))
++ if (!run("git config --get i18n.commitencoding", &runOutput))
+ return NULL;
+
+ if (runOutput.isEmpty()) // git docs says default is utf-8