aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/ucommon/Makefile9
-rw-r--r--devel/ucommon/distinfo4
-rw-r--r--devel/ucommon/files/patch-corelib_shell.cpp28
-rw-r--r--devel/ucommon/pkg-plist2
4 files changed, 39 insertions, 4 deletions
diff --git a/devel/ucommon/Makefile b/devel/ucommon/Makefile
index 6918dfe2f9a5..8044b3cb3f7b 100644
--- a/devel/ucommon/Makefile
+++ b/devel/ucommon/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ucommon
-PORTVERSION= 5.0.1
+PORTVERSION= 5.0.3
CATEGORIES= devel
MASTER_SITES= GNU
MASTER_SITE_SUBDIR= commoncpp
@@ -19,6 +19,11 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS}"
-MAN1= args.1 scrub.1 mdsum.1 zerofill.1 ucommon-config.1 commoncpp-config.1
+MAN1= args.1 car.1 commoncpp-config.1 mdsum.1 scrub.1 sockaddr.1 \
+ ucommon-config.1 zerofill.1
+
+post-patch:
+ ${REINPLACE_CMD} -e '/HAVE_OPENSSL_FIPS_H/s/define/undef/' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
.include <bsd.port.mk>
diff --git a/devel/ucommon/distinfo b/devel/ucommon/distinfo
index 156681ba5116..288d23a532d4 100644
--- a/devel/ucommon/distinfo
+++ b/devel/ucommon/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ucommon-5.0.1.tar.gz) = 0db6315855c06fe94e9bb3f1cc1dd0f11879767552477778a9c6f1fb866a4191
-SIZE (ucommon-5.0.1.tar.gz) = 739307
+SHA256 (ucommon-5.0.3.tar.gz) = 8f0081ac8d7993befafe54bc21673880a32158ccf2776ed2c16d49064b605544
+SIZE (ucommon-5.0.3.tar.gz) = 745615
diff --git a/devel/ucommon/files/patch-corelib_shell.cpp b/devel/ucommon/files/patch-corelib_shell.cpp
new file mode 100644
index 000000000000..32e33bc1bb27
--- /dev/null
+++ b/devel/ucommon/files/patch-corelib_shell.cpp
@@ -0,0 +1,28 @@
+--- corelib/shell.cpp.orig 2011-06-21 15:59:26.000000000 +0200
++++ corelib/shell.cpp 2011-06-21 16:03:35.000000000 +0200
+@@ -19,6 +19,7 @@
+ #include <ucommon/string.h>
+ #include <ucommon/memory.h>
+ #include <ucommon/shell.h>
++#include <stdio.h>
+ #include <stdlib.h>
+ #include <stdarg.h>
+ #ifdef HAVE_UNISTD_H
+@@ -1817,7 +1818,7 @@
+ fputs(prompt, stdout);
+
+ while(pos < size - 1) {
+- buffer[pos] = ::getchar();
++ buffer[pos] = getchar();
+ if(buffer[pos] == '\r' || buffer[pos] == '\n')
+ break;
+ else if(buffer[pos] == '\b' && pos) {
+@@ -1869,7 +1870,7 @@
+ noecho(1);
+ if(prompt)
+ fputs(prompt, stdout);
+- int ch = ::getchar();
++ int ch = getchar();
+ echo(1);
+
+ return ch;
diff --git a/devel/ucommon/pkg-plist b/devel/ucommon/pkg-plist
index c3ae32416fc8..e254dee40843 100644
--- a/devel/ucommon/pkg-plist
+++ b/devel/ucommon/pkg-plist
@@ -1,7 +1,9 @@
bin/args
+bin/car
bin/commoncpp-config
bin/mdsum
bin/scrub
+bin/sockaddr
bin/ucommon-config
bin/zerofill
include/commoncpp/address.h