aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/imake-4/Makefile12
-rw-r--r--devel/imake-4/distinfo3
-rw-r--r--devel/imake-4/files/patch-c12
-rw-r--r--devel/imake-4/files/patch-c211
-rw-r--r--devel/imake-4/files/patch-d6
-rw-r--r--devel/imake-4/files/patch-freetype11
-rw-r--r--devel/imake-4/files/patch-h20
-rw-r--r--devel/imake-4/files/patch-xthreads116
-rw-r--r--devel/imake-4/pkg-plist3
-rw-r--r--devel/imake-4/scripts/configure7
10 files changed, 71 insertions, 130 deletions
diff --git a/devel/imake-4/Makefile b/devel/imake-4/Makefile
index e7e48cdbf2e2..00c152880ed6 100644
--- a/devel/imake-4/Makefile
+++ b/devel/imake-4/Makefile
@@ -6,14 +6,11 @@
#
PORTNAME= imake
-PORTVERSION= 4.0.3
+PORTVERSION= 4.1.0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_XFREE}
-MASTER_SITE_SUBDIR= 4.0.2
-DISTFILES= X402src-1.tgz
-
-PATCH_SITES= ${MASTER_SITE_XFREE:S,%SUBDIR%/source,4.0.3/patches,g}
-PATCHFILES= 4.0.2-4.0.3.diff.gz
+MASTER_SITE_SUBDIR= 4.1.0
+DISTFILES= X410src-1.tgz
MAINTAINER= taguchi@tohoku.iij.ad.jp
@@ -26,7 +23,8 @@ EXTRACT_AFTER_ARGS= | ${TAR} -xf - xc/Imakefile \
xc/Makefile \
xc/config \
xc/include \
- xc/extras
+ xc/extras \
+ xc/programs/Xserver/hw/xfree86/xf86Version.h
MAN1= imake.1 \
lndir.1 \
makedepend.1 \
diff --git a/devel/imake-4/distinfo b/devel/imake-4/distinfo
index 073d54832d2d..e4b5e84b9421 100644
--- a/devel/imake-4/distinfo
+++ b/devel/imake-4/distinfo
@@ -1,2 +1 @@
-MD5 (xc/X402src-1.tgz) = d314c311aa4a29d74695b0e39b6d80c4
-MD5 (xc/4.0.2-4.0.3.diff.gz) = c8bb56df966dd0a51d2291bca36e0ea4
+MD5 (xc/X410src-1.tgz) = 2d4709f7106a1d65c175be445a3d3c32
diff --git a/devel/imake-4/files/patch-c b/devel/imake-4/files/patch-c
index f5b0ae491d7c..b1d7af2cbc63 100644
--- a/devel/imake-4/files/patch-c
+++ b/devel/imake-4/files/patch-c
@@ -1,18 +1,18 @@
---- cf/Imake.tmpl.orig Tue Dec 5 10:16:28 2000
-+++ cf/Imake.tmpl Tue Dec 5 10:39:48 2000
-@@ -1425,7 +1425,7 @@
+--- cf/Imake.tmpl.orig Fri Apr 27 06:09:38 2001
++++ cf/Imake.tmpl Mon Jun 4 19:29:44 2001
+@@ -1487,7 +1487,7 @@
CXXOPTIONS = CplusplusOptions
CXXINCLUDES = $(INCLUDES) $(TOP_INCLUDES) $(CXXEXTRA_INCLUDES)
- CXXDEFINES = $(CXXINCLUDES) $(CXXSTD_DEFINES) $(THREADS_CXXDEFINES) $(CXXEXTRA_DEFINES) $(DEFINES)
+ CXXDEFINES = $(CXXINCLUDES) $(CXXSTD_DEFINES) $(THREADS_CXXDEFINES) $(DEFINES) $(CXXEXTRA_DEFINES)
- CXXFLAGS = $(CXXDEBUGFLAGS) $(CXXOPTIONS) $(THREADS_CXXFLAGS) $(CXXDEFINES)
+ CXXFLAGS += $(CXXDEBUGFLAGS) $(CXXOPTIONS) $(THREADS_CXXFLAGS) $(CXXDEFINES)
#endif
COMPRESS = CompressCmd
GZIPCMD = GzipCmd
-@@ -1616,7 +1616,7 @@
+@@ -1682,7 +1682,7 @@
*/
ALLINCLUDES = $(INCLUDES) $(EXTRA_INCLUDES) $(TOP_INCLUDES) $(STD_INCLUDES)
- ALLDEFINES = $(ALLINCLUDES) $(STD_DEFINES) $(EXTRA_DEFINES) $(PROTO_DEFINES) $(THREADS_DEFINES) $(MODULE_DEFINES) $(DEFINES)
+ ALLDEFINES = $(ALLINCLUDES) $(STD_DEFINES) $(PROTO_DEFINES) $(THREADS_DEFINES) $(MODULE_DEFINES) $(DEFINES) $(EXTRA_DEFINES)
- CFLAGS = $(CDEBUGFLAGS) $(CCOPTIONS) $(THREADS_CFLAGS) $(MODULE_CFLAGS) $(ALLDEFINES)
+ CFLAGS += $(CDEBUGFLAGS) $(CCOPTIONS) $(THREADS_CFLAGS) $(MODULE_CFLAGS) $(ALLDEFINES)
LINTFLAGS = $(LINTOPTS) -DLINT $(ALLDEFINES) $(DEPEND_DEFINES)
diff --git a/devel/imake-4/files/patch-c2 b/devel/imake-4/files/patch-c2
index 89ebb285a674..e21cf3c0df0a 100644
--- a/devel/imake-4/files/patch-c2
+++ b/devel/imake-4/files/patch-c2
@@ -1,8 +1,11 @@
---- cf/Library.tmpl Wed Oct 13 00:20:41 1999
-+++ cf/Library.tmpl Thu Dec 21 09:22:14 2000
-@@ -69,3 +69,3 @@
+--- cf/Library.tmpl.orig Thu Jan 18 01:22:30 2001
++++ cf/Library.tmpl Mon Jun 4 19:30:34 2001
+@@ -67,7 +67,7 @@
+ STD_DEFINES = LibraryDefines $(PROJECT_DEFINES)
+ CDEBUGFLAGS = LibraryCDebugFlags
CLIBDEBUGFLAGS = LibraryDebugOpt
- CFLAGS = $(CDEBUGFLAGS) $(CLIBDEBUGFLAGS) $(CCOPTIONS) $(THREADS_CFLAGS) $(ALLDEFINES)
+ CFLAGS += $(CDEBUGFLAGS) $(CLIBDEBUGFLAGS) $(CCOPTIONS) $(THREADS_CFLAGS) $(ALLDEFINES)
# if defined(LargePICTable) && LargePICTable && defined(LargePositionIndependentCFlags)
-
+ PICFLAGS = LargePositionIndependentCFlags
+ # endif
diff --git a/devel/imake-4/files/patch-d b/devel/imake-4/files/patch-d
index 27ec6db7e147..3b1b280c237c 100644
--- a/devel/imake-4/files/patch-d
+++ b/devel/imake-4/files/patch-d
@@ -1,6 +1,6 @@
---- cf/FreeBSD.cf~ Tue Dec 5 10:16:28 2000
-+++ cf/FreeBSD.cf Tue Dec 5 10:45:42 2000
-@@ -371,14 +371,14 @@
+--- cf/FreeBSD.cf.orig Fri May 4 05:12:35 2001
++++ cf/FreeBSD.cf Mon Jun 4 19:31:27 2001
+@@ -444,14 +444,14 @@
/* The GCC strength-reduce bug is fixed for FreeBSD 2.1.5 and later */
#ifndef DefaultGcc2i386Opt
#if OSMajorVersion > 2 || (OSMajorVersion == 2 && OSMinorVersion > 1) || (OSMajorVersion == 2 && OSMinorVersion == 1 && OSTeenyVersion >= 5)
diff --git a/devel/imake-4/files/patch-freetype b/devel/imake-4/files/patch-freetype
new file mode 100644
index 000000000000..6bb066df1760
--- /dev/null
+++ b/devel/imake-4/files/patch-freetype
@@ -0,0 +1,11 @@
+--- cf/X11.tmpl.orig Sat Jun 2 07:21:30 2001
++++ cf/X11.tmpl Fri Jun 8 00:44:19 2001
+@@ -2453,7 +2453,7 @@
+ FREETYPE2DIR = Freetype2Dir
+ FREETYPE2LIBDIR = Freetype2LibDir
+ FREETYPE2INCDIR = Freetype2IncDir
+-FREETYPE2INCLUDES = -I$(FREETYPE2INCDIR)
++FREETYPE2INCLUDES = -I$(FREETYPE2INCDIR) -I$(FREETYPE2DIR)/include
+ FREETYPE2LIB = -L$(FREETYPE2LIBDIR) -lfreetype
+ FREETYPE2DEFINES = -DFREETYPE2
+ #endif
diff --git a/devel/imake-4/files/patch-h b/devel/imake-4/files/patch-h
index 89b9f99e3e86..3d093aaebfa2 100644
--- a/devel/imake-4/files/patch-h
+++ b/devel/imake-4/files/patch-h
@@ -1,24 +1,24 @@
---- cf/Imake.rules~ Tue Dec 5 10:16:28 2000
-+++ cf/Imake.rules Tue Dec 5 11:01:00 2000
-@@ -1303,7 +1303,7 @@
- dest.suffix.html: file.man RmanCmdDependency @@\
+--- cf/Imake.rules.orig Fri Apr 27 06:27:48 2001
++++ cf/Imake.rules Mon Jun 4 19:56:42 2001
+@@ -1388,7 +1388,7 @@
+ dest.suffix.html: file.$(MANNEWSUFFIX) RmanCmdDependency @@\
RemoveFiles(dest.suffix.html dest.suffix-html) @@\
- RunProgram(RMAN,$(RMANOPTIONS) < file.man > dest.suffix-html) && \ @@\
-- $(MV) dest.suffix-html $@ @@\
-+ $(MV) dest.suffix-html dest.suffix.html @@\
+ RunProgram(RMAN,$(RMANOPTIONS) < file.$(MANNEWSUFFIX) \ @@\
+- > dest.suffix-html) && $(MV) dest.suffix-html $@ @@\
++ > dest.suffix-html) && $(MV) dest.suffix-html dest.suffix.html @@\
@@\
install.man:: dest.suffix.html @@\
MakeDir($(DESTDIR)$(DOCHTMLDIR)) @@\
-@@ -1539,7 +1539,7 @@
+@@ -1624,7 +1624,7 @@
MakeDir(Concat($(DESTDIR),npath/mdir)) @@\
@MakeFlagsToShellFlags(i,set +e); \ @@\
if [ -d Concat($(DESTDIR),opath/cdir) ]; then \ @@\
- RELPATH=`echo opath/cdir | \ @@\
-+ RELPATH=`cd opath/cdir; pwd | \ @@\
++ RELPATH=`cd opath/cdir; pwd | \ @@\
sed -e 's:^.::' -e 's:[^/.][^/]*:..:'g`; \ @@\
cd Concat($(DESTDIR),opath/cdir); \ @@\
if [ -d rdir -a ! -h rdir ]; then \ @@\
-@@ -1586,7 +1586,7 @@
+@@ -1671,7 +1671,7 @@
MakeDir(Concat($(DESTDIR),npath)) @@\
@MakeFlagsToShellFlags(i,set +e); \ @@\
if [ -d Concat($(DESTDIR),opath) ]; then \ @@\
diff --git a/devel/imake-4/files/patch-xthreads b/devel/imake-4/files/patch-xthreads
index 0be90302ebd7..f4bb8d98b3b9 100644
--- a/devel/imake-4/files/patch-xthreads
+++ b/devel/imake-4/files/patch-xthreads
@@ -1,101 +1,25 @@
---- ../include/Xos_r.h.orig Sat Mar 24 16:49:23 2001
-+++ ../include/Xos_r.h Sat Mar 24 16:49:25 2001
-@@ -245,7 +245,7 @@
-
- /* NetBSD, at least, is missing several of the unixware passwd fields. */
-
--#if defined(__NetBSD__) || defined(__OpenBSD__)
-+#if defined(__NetBSD__) || defined(__OpenBSD__) || defined(__FreeBSD__)
- __inline__ void _Xpw_copyPasswd(_Xgetpwparams p)
- {
- memcpy(&(p).pws, (p).pwp, sizeof(struct passwd));
-@@ -412,7 +412,7 @@
- /* UnixWare 2.0, or other systems with thread support but no _r API. */
- /* WARNING: The h_addr_list and s_aliases values are *not* copied! */
-
--#if defined(__NetBSD__)
-+#if defined(__NetBSD__) || defined(__FreeBSD__)
- #include <sys/param.h>
- #endif
-
---- cf/FreeBSD.cf.orig Sat Mar 24 16:49:25 2001
-+++ cf/FreeBSD.cf Sat Mar 24 16:49:49 2001
-@@ -66,6 +66,41 @@
- #define InstallXloadSetGID YES
- #endif
-
-+/*
-+ * Multi-thread safe libs
-+ */
-+/* 2.2.7 and later has libc_r (POSIX threads) */
-+#if OSMajorVersion == 2 && OSMinorVersion == 2 && OSTeenyVersion >= 7 || \
-+ OSMajorVersion >= 3
-+# ifndef HasLibPthread
-+# define HasLibPthread NO
-+# endif
-+# define HasPosixThreads YES
-+# define ThreadedX YES
-+/*
-+ * math.h uses _REENTRANT and stdio.h uses _THREAD_SAFE, so define both.
-+ */
-+# define SystemMTDefines -D_REENTRANT -D_THREAD_SAFE
-+/*
-+ * FreeBSD has tread-safe api but no getpwnam_r yet.
-+ */
-+# define HasThreadSafeAPI YES
-+# define MTSafeAPIDefines -DXUSE_MTSAFE_API -DXNO_MTSAFE_PWDAPI
-+# if HasLibPthread
-+# define ThreadsLibraries -lpthread
-+# else
-+# define BuildThreadStubLibrary YES
-+# define NeedUIThrStubs YES
+--- cf/FreeBSD.cf.orig Thu Jun 7 16:25:47 2001
++++ cf/FreeBSD.cf Thu Jun 7 16:28:30 2001
+@@ -80,7 +80,6 @@
+ /*
+ * math.h uses _REENTRANT and stdio.h uses _THREAD_SAFE, so define both.
+ */
+-# define SystemMTDefines -D_REENTRANT -D_THREAD_SAFE
+ /*
+ * FreeBSD has tread-safe api but no getpwnam_r yet.
+ */
+@@ -91,8 +90,12 @@
+ # else
+ # define BuildThreadStubLibrary YES
+ # define NeedUIThrStubs YES
+-# define ThreadsCompileFlags -pthread
+-# define ThreadsLibraries -pthread
+# if (OSRelVersion >= 500016)
+# define ThreadsLibraries -lc_r
+# else
++# define SystemMTDefines -D_REENTRANT -D_THREAD_SAFE
+# define ThreadsLibraries -pthread
+# endif
-+# define SharedX11Reqs $(LDPRELIB) $(XTHRSTUBLIB)
-+# define SharedXtReqs $(LDPRELIB) $(XLIBONLY) $(SMLIB) $(ICELIB) $(XTHRSTUBLIB)
-+# endif
-+#endif
-+
- #define AvoidNullMakeCommand YES
- #define StripInstalledPrograms YES
- #define CompressAllFonts YES
-@@ -97,7 +132,23 @@
- #endif
- #endif
-
--#define CcCmd cc
-+/*
-+ * Add an LD_LIBRARY_PATH environment variable, defined by $(CLIENTENVSETUP),
-+ * when building X to avoid that for each client ld give the message
-+ *
-+ * ld: warning: libXThrStub.so.6, needed by libX11.so, not found
-+ */
-+#if BuildThreadStubLibrary && !UseInstalled
-+# define CcCmd $(CLIENTENVSETUP) cc
-+# define CplusplusCmd $(CLIENTENVSETUP) c++
-+#else
-+# define CcCmd cc
-+# define CplusplusCmd c++
-+#endif
-+
-+#define CppCmd /usr/bin/cpp
-+#define PreProcessCmd CppCmd
-+#define StandardCppOptions -traditional
- #define CppCmd /usr/bin/cpp
- #define PreProcessCmd CppCmd
- #define StandardCppOptions -traditional
---- cf/bsdLib.tmpl.orig Tue Aug 29 03:43:49 2000
-+++ cf/bsdLib.tmpl Sat Mar 24 16:49:25 2001
-@@ -47,7 +47,9 @@
- #define SharedX11Reqs
- #endif
- #define SharedOldXReqs $(LDPRELIB) $(XLIBONLY)
-+#ifndef SharedXtReqs
- #define SharedXtReqs $(LDPRELIB) $(XLIBONLY) $(SMLIB) $(ICELIB)
-+#endif
- #define SharedXawReqs $(LDPRELIB) $(XMULIB) $(XTOOLLIB) $(XPMLIB) $(XLIB)
- #define SharedXaw6Reqs $(LDPRELIB) $(XMULIB) $(XTOOLLIB) $(XLIB)
- #define SharedXmuReqs $(LDPRELIB) $(XTOOLLIB) $(XLIB)
+ # define SharedX11Reqs $(LDPRELIB) $(XTHRSTUBLIB)
+ # define SharedXtReqs $(LDPRELIB) $(XLIBONLY) $(SMLIB) $(ICELIB) $(XTHRSTUBLIB)
+ # endif
diff --git a/devel/imake-4/pkg-plist b/devel/imake-4/pkg-plist
index 7cb86b0a10de..aafcc5dfda8a 100644
--- a/devel/imake-4/pkg-plist
+++ b/devel/imake-4/pkg-plist
@@ -1,3 +1,5 @@
+bin/ccmakedep
+bin/cleanlinks
bin/gccmakedep
bin/imake
bin/lndir
@@ -107,6 +109,7 @@ lib/X11/config/svr3.cf
lib/X11/config/svr4.cf
lib/X11/config/ultrix.cf
lib/X11/config/usl.cf
+lib/X11/config/version.def
lib/X11/config/x386.cf
lib/X11/config/xf86.rules
lib/X11/config/xf86.tmpl
diff --git a/devel/imake-4/scripts/configure b/devel/imake-4/scripts/configure
index 634ecb077ed5..e46a17fae410 100644
--- a/devel/imake-4/scripts/configure
+++ b/devel/imake-4/scripts/configure
@@ -125,12 +125,14 @@ if [ X$BuildTTFonts != "X" ]; then
fi
echo "#define BuildXF86Setup NO" >> $F
+echo "#define HasFreetype2 YES" >> $F
+echo "#define Freetype2Dir ${LOCALBASE}" >> $F
cat >> $F <<EOF
#ifndef XF86CardDrivers
#ifdef i386Architecture
#define XF86CardDrivers mga glint nv tga s3virge sis rendition \
neomagic i740 tdfx savage \
- cirrus tseng trident chips apm \
+ cirrus vmware tseng trident chips apm \
GlideDriver fbdev i128 \
ati AgpGartDrivers DevelDrivers ark cyrix \
siliconmotion \
@@ -155,5 +157,6 @@ cat $F >> ${WRKDIR}/xc/config/cf/xf86site.def
echo "#define ProjectRoot ${PREFIX}" > ${WRKDIR}/xc/config/cf/host.def
cd ${WRKDIR}/xc
+touch config/cf/version.def
make Makefile.boot
-make -f xmakefile SUBDIRS="include config" VerifyOS Makefiles includes
+make -f xmakefile SUBDIRS="include config" VerifyOS version.def Makefiles includes