aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/RStudio/Makefile2
-rw-r--r--devel/eric6/Makefile3
-rw-r--r--devel/gammaray/Makefile3
-rw-r--r--devel/kdevelop/Makefile7
-rw-r--r--devel/libosmo-abis/Makefile3
-rw-r--r--devel/pyside2-tools/Makefile2
-rw-r--r--devel/pyside2/Makefile2
-rw-r--r--devel/qt5/Makefile4
-rw-r--r--devel/qtcreator/Makefile5
9 files changed, 30 insertions, 1 deletions
diff --git a/devel/RStudio/Makefile b/devel/RStudio/Makefile
index 698ab9d5b1c9..2355b8a0aee1 100644
--- a/devel/RStudio/Makefile
+++ b/devel/RStudio/Makefile
@@ -61,6 +61,8 @@ GWT_VERSION= 2.8.1
GIN_VERSION= 2.1.2
.if ${FLAVOR:U} == desktop
+DEPRECATED= Uses EOL Python 2.7 via www/qt5-webengine
+EXPIRATION_DATE=2021-06-23
COMMENT+= (desktop UI version)
USES+= desktop-file-utils qt:5 shared-mime-info
USE_QT= core dbus declarative gui location network opengl printsupport quickcontrols sensors \
diff --git a/devel/eric6/Makefile b/devel/eric6/Makefile
index 2e29b46713e6..674d5d27637f 100644
--- a/devel/eric6/Makefile
+++ b/devel/eric6/Makefile
@@ -8,6 +8,9 @@ DISTNAME= ${PORTNAME}-nolang-${DISTVERSION}
PORTREVISION= 3
CATEGORIES= devel python
+DEPRECATED= Uses EOL Python 2.7 via www/py-qt5-webengine
+EXPIRATION_DATE=2021-06-23
+
BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pip>0:devel/py-pip@${PY_FLAVOR}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
diff --git a/devel/gammaray/Makefile b/devel/gammaray/Makefile
index a249b34f8a95..2d908cffaaa4 100644
--- a/devel/gammaray/Makefile
+++ b/devel/gammaray/Makefile
@@ -9,6 +9,9 @@ CATEGORIES= devel
MAINTAINER= swills@FreeBSD.org
COMMENT= Debugging tool for Qt-application
+DEPRECATED= Uses EOL Python 2.7 via www/qt5-webengine
+EXPIRATION_DATE=2021-06-23
+
USES= cmake kde:5 pkgconfig qt:5
USE_QT= 3d concurrent core declarative designer gui help linguisttools \
diff --git a/devel/kdevelop/Makefile b/devel/kdevelop/Makefile
index 06cacdae34fc..c2e4205077fd 100644
--- a/devel/kdevelop/Makefile
+++ b/devel/kdevelop/Makefile
@@ -59,4 +59,11 @@ SHEBANG_LANG= zsh
zsh_OLD_CMD= /bin/zsh
zsh_CMD= ${LOCALBASE}/bin/zsh
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MWEBENGINE}
+DEPRECATED= Uses EOL Pyton 2.7 via www/qt5-webengine
+EXPIRATION_DATE=2021-06-23
+.endif
+
.include <bsd.port.mk>
diff --git a/devel/libosmo-abis/Makefile b/devel/libosmo-abis/Makefile
index 6075f519d1f8..6429b2ea17e0 100644
--- a/devel/libosmo-abis/Makefile
+++ b/devel/libosmo-abis/Makefile
@@ -11,6 +11,9 @@ COMMENT= Shared code regarding the A-bis interface between BTS and BSC
LICENSE= AGPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
+DEPRECATED= Uses EOL Python 2.7 via devel/libosmocore
+EXPIRATION_DATE=2021-06-23
+
LIB_DEPENDS= libosmocore.so:devel/libosmocore \
libtalloc.so:devel/talloc \
libortp.so:net/ortp
diff --git a/devel/pyside2-tools/Makefile b/devel/pyside2-tools/Makefile
index 26d44c08d3a6..c228975dcb8e 100644
--- a/devel/pyside2-tools/Makefile
+++ b/devel/pyside2-tools/Makefile
@@ -36,6 +36,8 @@ CMAKE_ARGS+= "-DUSE_PYTHON_VERSION=${PYTHON_VER}"
WRKSRC= ${WRKDIR}/pyside-setup-opensource-src-${DISTVERSION:C/^([0-9].[0-9]+.[0-9])(.[0-9])?/\1/}/sources/pyside2-tools
.if ${ARCH} == amd64 || ${ARCH} == i386
+DEPRECATED= Uses EOL Python 2.7 via www/qt5-webengine
+EXPIRATION_DATE=2021-06-23
USE_QT+= webengine
.endif
diff --git a/devel/pyside2/Makefile b/devel/pyside2/Makefile
index aa735888a249..a9795dc545dd 100644
--- a/devel/pyside2/Makefile
+++ b/devel/pyside2/Makefile
@@ -37,6 +37,8 @@ PLIST_SUB+= DISTVERSION=${DISTVERSION}
WRKSRC= ${WRKDIR}/pyside-setup-opensource-src-${DISTVERSION:C/^([0-9].[0-9]+.[0-9])(.[0-9])?/\1/}/sources/pyside2
.if ${ARCH} == amd64 || ${ARCH} == i386
+DEPRECATED= Uses EOL Python 2.7 via www/qt5-webengine
+EXPIRATION_DATE=2021-06-23
PLIST_SUB+= WEBENGINE=""
USE_QT+= webengine
.else
diff --git a/devel/qt5/Makefile b/devel/qt5/Makefile
index 997be9942b10..df08e9d96ee1 100644
--- a/devel/qt5/Makefile
+++ b/devel/qt5/Makefile
@@ -2,6 +2,7 @@
PORTNAME= qt5
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= devel
MAINTAINER= kde@FreeBSD.org
@@ -9,7 +10,8 @@ COMMENT= Cross-platform application and UI framework (metaport)
# * phonon4 is not part of Qt itself.
# * we don't want to pull in wayland just yet.
-USE_QT= ${_USE_QT_ALL:Nphonon4:Ndeclarative:Nwayland:S/$/_run/}
+# XXX(rene) exclude webengine
+USE_QT= ${_USE_QT_ALL:Nphonon4:Ndeclarative:Nwayland:Nwebengine:S/$/_run/}
USES= metaport qt:5
.include <bsd.port.mk>
diff --git a/devel/qtcreator/Makefile b/devel/qtcreator/Makefile
index 4d1106db532d..697d53536199 100644
--- a/devel/qtcreator/Makefile
+++ b/devel/qtcreator/Makefile
@@ -86,6 +86,11 @@ SHEBANG_FILES= tests/system/tools/objectsToTable.py \
.include <bsd.port.pre.mk>
+.if ${PORT_OPTIONS:MWEBENGINE}
+DEPRECATED= Uses EOL Python 2.7 via www/qt5-webengine
+EXPIRATION_DATE=2021-06-23
+.endif
+
.if ${LLVM_DEFAULT:C/[1-5]./&0/:S,-devel,990,} >= 90
LLVM_DEFAULT= 80
.endif